My Cloud Home Device Name Just Changed?

I had mapped a drive to MyCloud-NNNNNN\Public (where “NNNNNN” is the last 6 digits of my unit’s S/N). I used that Public area for Windows File History backups.

Yesterday, the device mapping failed. When I investigate, I noticed the device name had somehow changed from “MyCloud-NNNNNN” to
“My Cloud_b5792ebdb87e90aafbb9a906995xxxxx”

WD Discovery still has Z: mapped to its Private area, but I can no longer map a drive to the \Public area.

Coincidently(?) I upgraded WD Discovery from v4.3.336 to v4.3.361 yesterday then noticed the issue.

But I suspect that Windows Update KB890830 may have caused the issue. I have 3 computers:
#1 Win11, with WD Discovery upgraded yesterday to v4.3.361, received KB890830 on 2/9 and exhibits this issue
#2 Win10, with WD Discovery v4.3.336, received KB890830 on 2/8 and exhibits this issue
#3 Win10, with WD Discovery v4.3.336, did NOT receive KB890830, all previous mappings to Z:Private and Y:Public are still working fine only on this computer! (I just turned off Windows Updates!)

Any ideas how to resolve this issue and restore my device name back to the original “MyCloud-NNNNNN” on two of my 3 computers on the SAME Network?

Yes, don’t be a beta tester for MS or WD. Try to stay with versions that worked and delay updating as long as possible. Always keep legacy full install copies of WD Discovery around so that you can roll back to earlier versions that worked. The full install is usually available here:
WD Discovery Full installer for Windows

That is the ‘private space’ kddfs virtual file system mapped from net use and not the ‘public’ LAN share. They are not interchangeable.

Thank you for your feedback. I agree, I normally delay upgrading SW until a future date, but recently purchased a new PC with Windows 11 and still getting everything running.

Yes, the My Home Cloud unit has both a Private and Public LAN share space. I used to be able to access both without any issues on all 3 computers. But just this week, two can no longer see nor map to the Public space. I think it was a Windows update that affected both my Win11 and one of my Win10 computers. I’ve tried uninstalling that update on one PC but problem still exits. I opened a Case with WD last Thursday since I assume others users may have been affected as well, just want to map to that Public LAN space on all 3 computers again!