My Cloud Home 6TB suddenly stops working

I bought the device on June 28th 2018, and it’s been working fine until yesterday morning, I checked the LED indicator, its blinking slowly, so I’ve tried several solution provided by the support page

  1. Unplug the power supply and wait a few minutes before plugging it back.
  2. Restart my router, disconnecting and reconnecting the lan cable making sure it was connected properly.
  3. I tried Pin resetting for 1 - 5 secs.

All solution failed and my device still not working.

What I want to ask is:

  1. have I already tried every possible solution available? If not can someone provide me or give me solution.
  2. If all possible solution fails, then I have no choice but to RMA the product, can I somehow access the content of my cloud home before I RMA? Because in my country, the can’t offer backup service, they can only provide product replacement if my current product is defected or broken.


Slow Breathing LED could mean a connectivity issue between your MCH and the My Cloud Servers. Have you rebooted your network router? Try connecting the MCH to a different network and try to access using mobile app.

I have rebooted (or should I say restart in my original post) my network router, currently I even tried a different router. But all seem have no effect whatsoever.

I haven’t tried a different network, because it’s the only one currently I have in my home at the moment.
I probably try this tomorrow at my office’s network, and see if it make a difference.