My Cloud doesn't stream locally but it can play remotely

I have a weird situation here, I can stream my music and videos if I use my phone 4G data but I cannot stream them if I am connected to my home local network which is the same as the My Cloud device.

Few days ago I called my ISP to change my IP address because my internet got disconnected quite frequently and a friend recommended me to do it. (I don’t know if this is the issue, probably it is). The frequent disconnection somehow seems to stop but things started to get weird, I can’t play the music or videos via My Cloud app locally on my phone but I can download them and play it. Worse still, I can’t connect to the My Cloud website, the website says it’s offline. I tried system restore twice but it’s the same.

What should I do? I’m not a tech savvy guy so I’m kind of lost over here. My router is the Google WIFI.

There’s your problem.
Google WiFi network have DNS Rebinding Disabled by default.
Just login to your Google Wifi and add google DNS Server 8.8.8.8 and your local LAN problem should be resolved. You many also have some sort of Google Firewall or Increase Security stuff enabled as well, but the DNS change should fix it.

Thanks for the update! I’ve just switched my Google WIFI router DNS to the Google DNS. I’ve also rebooted the Google router and the MyCloud device but the app still doesn’t want to play any videos via WIFI and My Cloud account still thinks the device is offline. Previously I was using my own ISP DNS and it was working fine so I think it might not be the issue with the router DNS…? I wonder what else can I do now? Any suggestions?

Okie this is confusing, previously I have been using my WIFI to access my cloud account and it says the device is offline. I’ve just tried using my phone 4G data and the device is connected again. I’m not sure what happened why the device doesn’t let me use my WIFI lol.