My Cloud App wont authenticate after reinstall

I’ve had to remove and reinstall my “My Cloud” app after having connection problems with my My Cloud Drive repeatedly going offline, (during this process the IP address of my My Cloud drive is now different from before if this is relevant) the problem I have now is that after generating a Remote Device code in my Dashboard, the device wont authenticate and confirm in the dashboard, the WD Photos app works fine after reinstalling and generating a new code but the My Cloud App wont, I can open the My Cloud app and view my device and all the folders etc but only if I’m not connected to my Wifi network, if I switch my iPhone to cellular data it works fine, and the problem is exactly the same on my iPad too, the WD Photos app works fine but not the My Cloud app.

I’m concerned that when the authentication code expires for the device, it wont allow me to manage my folders etc.

Any advice is gratefully appreciated.

did you check to see if the devices were previously removed before re-authenticating?

Very similar issue with me. MyCloud worked great right upto the software update in Jan. After that, no access at all. Rebooted the drive, got access back on my network and on wifi but now no access remotely through Android WD app or website. Tried several options on this forum and no luck. I’ve just opened a ticket with WD support. Anyone else experience this specific issue?

See if this helps you.

All previous devices had been removed before attempting to generate and register a new code for the app, have tried several times, WD Photos is working fine, just My Cloud app wont authenticate to allow wireless network acces, I can use it fine over cell, but it wont work at all on the same wifi network as my My Drive device.

Did you just update your Java recently?  If so, check this thread out.

My Java has been updated but I only updated it after I discovered I couldn’t access my drive via the app and attempted to connect using my computer.

If you’re using Java 7.51, make sure to follow the instructions in that thread I posted to drop the security settings down.  Let us know what happens.