My cloud app will not "access" my my book live device

PLEASE HELP ME!!! I used to use the app WD2GO on my iphone to be able to see photos (etc) that were stored
on my “my book live” device. It worked great. Then, WD replaced the app with “my cloud app”. It still worked.
NOW WD installed a new version of the app & it wants me to connect via a web sign in. BUT I cannot create a wen sign in because the web sign in only looks for a "my cloud deviced…not a my book live device.

Try re-enabling access from within your WD My Book Live. If you try to pair devices within the same WiFi network the app should detect your unit.

Thanks for the reply. If I connect the app within my home…(where i can access MY WiFi) it works great. Within the app it says “connect to a local decice”. My problem is when I am away from home (even if i am on another WiFi) the only option on the app is to sign in to the web based “my cloud”. I tried to establish a web “my cloud” account on the WD web site…BUT when I attempt to do that it searches for a physical MY CLOUD DRIVE. I do not have one…I have a MY BOOK DRIVE.

This is very unusual. The app should not ask you to log in again in a different network after your account is activated. Do you get the same issue if you re-install the app?

It is not asking me to sign in again to another network…it requires me to log on to the internet
with a “my cloud” account.

yes…i reinstalled the app

Did you manage to resolve this? I have the same issue.

Good luck…

No…I never got the issue resolved. I spent 20-30 hours try to research/solve the issue. In my opinion,
this is a “dirty little secret” on WD’s part. WD eliminated the old app “WD-to-go” and replaced it with a new app
“my Cloud”…KNOWING that the new app would not work with the device “MYBOOKLIVE”…it only work with
the “MYCLOUD” device. Why? Simple…they want you to buy a new MYCLOUD drive.

My solution to the problem? I junked my old MYBOOKLIVE and purchased a new network drive from Seagate called
Personal cloud. It was cheaper & works great.

I will not do business with WD again…



Yes, the same happend to me.
Since they changed to MyCloud, I cannot access to my MyBookLive…


In my opinion…it is very sad that a company like Western Digital has to resort to such practices just to sell
more MyCloud devices. Just wait…in two or three years they will release myCloud2…and the apps will not support that.
A never ending cycle just to generate business.

As I said…I will NEVER do business with WD again.


i have both. wd live and my cloud
both work on app my cloud with no problem at all.

I have no doubt that is possible. Did you establish your ‘net MyCloud account BEFORE you had the MyCloud device? In other words…did you get the app working with your WDLive device…by itself…or did you get the app working with your MyCloud device and then “add” your WDLive device. According to WD tech support, the app is supposed to function with my MyBookLive device…BUT the catch22 is that in order to get the app to function, you need a ‘net MYCLOUD account. When I try to create a ‘net account it searches for a MYCloud device (and since I do not own one) and does NOT create the account & does not give me any other options. Nobody @ WD support has been able to help me…all they say is that “it is supposed to work”.

So, if you were able to get the app to work with JUST your WDLive device…I would very much like to know how you did it.



I add my passport wireles, my book live and my book cloud.
I don’t remember did I creat my cloud account first.
i will try tomorroy clean install for you.