My Cloud 4TB setup error


I bought My Cloud 4TB and I cannot find it in my network. The blue light is stable and I’ve done the procedure a lot of times.

What should I do?? 

Thank you!

I had trouble on my first attempt.  Unplug the MyCloud power, and the ethernet cable to your router.  Also power down your router.  Let everything sit for 30 seconds unplugged.  Plug your ethernet cable into an alternate port of your router if at all possible.  Power up your Mycloud, then power up your router.  Wait until you get the steady blue light…then see if you can proceed.  It worked for me.

This can occur if the ports on the router are not set up correctly. I agree re changing the port; maybe try a port you know is working to confirm whether that is the problem?

I tried it. Nothing changed.

I dont know what to do and I want to activate it as soon as possible!

Any other ideas? :cry:

what are the lights on the front and back of the mycloud doing?

can you go into the router setup and see if it is finding the mycloud?

is this a brand new unit? Or has it been working before?

In the front there is a blue stable light.

Behind, there are 2 yellow lights (ethernet’s light)

No I cannot find it from my router…

Seriously, I dont know what to do!

It is a brand new unit, I bought it from

what are the 2 yellow light doing?

do you have DHCP enabled in you router? this is needed at least for initial setup. reboot the router if you haven’t yet

if DHCP in the router is enabled it is possiable the mycloud is not trying DHCP. try the button reset, see manual for details. 1 is press button for 4 seconds with device one. the other is a system only restore remove power, hold rear button, oweron and continue to hold for 40 seconds

also how are you “looking” for it in the network?

The one is stable the other one it flashes.

How can I enable the DHCP? because i think this is the problem. To enable the DHCP i think I need to put an ip adress 

through the WD My Cloud Setup program by WD

well, I can see the unit on the “Allocated devices” in the LAN section on my router but again, I cannot find the unit on my network…


try going to http://wdmycloud/UI from internet explorer and \wdmycloud in file explorer. the “setup” program is not needed and is only a shortcut and is possiable that is the issue

if you are asking about enabling DHCP in your router you need to check your manual as all routers are different. If you are talking about enabling in the my cloud I believe the 4 second reset will enable it and i know the 40 second reset will enable it.

is the mycloud connected directly to your router? or through another device?

ijohn wrote:

well, I can see the unit on the “Allocated devices” in the LAN section on my router but again, I cannot find the unit on my network…


what IP address are you seeing assignd to the mycloud in the router? Try using this IP in the steps I posted above instead of wdmycloud.

if this dosn’t work open a command prompt and ping the IP address of the mycloud

Windows is somtimes terrible in resolving names on home networks. this is 1 reason I always suggest setting static IP addresses for networ devices. however this can’t be done until you get access to the device

It is connected directly to the router.

Ip for my cloud:

With this ip i can access my cloud via internet.

no, that IP is internal only

can you access it with a web browser ? and finder by entering the IP?

after you get access to the UI/Dashboard you can configure the device including remote access. remote access wil be from the WD apps or the website.

Yes, I can access my unit though .

How can I get the desktop app? 

you said from the Internet and you can’t access that IP from the Internet. from the local network yes

what desktop app? for smart phones/tablets from the appropiate app store. I don’t know if there is a mac version, if there is it will be on the site. For remote access the app is better then the site at least in Windows. For local access finder is should be beter then the app for most things.

have you created your users and shares yet? setup remote access?

take your time and be patient. it is a little slow to start but once it stabilizes it works well

Yes I created my users and shares.

I downloaded the desktop app for Mac from here:

Do you know how can i transfer all my data from dropbox and from hard disk?

what are you plans for the mycloud? I use it for backup and remote access, primary copy still on the PC.

in Windows the dropbox looks like another network drive so you can copy to an from it. no idea if Mac is the same

for local files I have 2 backup procedures in place a batch file and smartware, I think mac uses time machine

always maintain a backup copy