My Cloud 3TB disconnecting overnight - still pinging


#1

My 3TB My Cloud has started disconnecting over the last few days. This always happens overnight. When it happens, I can’t reattach mapped folders or web browse to the GUI, but I can still ping the ip address, with ping times of <1ms, and connect by ssh ok. When this happens it takes a full reboot of the My Cloud to get it working again.

There is nothing in the notifications log to say anything untoward has happened. Software version is 1.0.7.5.


#2

Since you can ssh into the device. Try stopping samba and restarting samba.


#3

While I understand this may allow the drive to reconnect, it doesn’t address what exactly is causing the problem in the first place.


#4

Well for one. If it works you won’t have to reboot to get the disk back. Every solution requires multiple steps to find
the fix. This is one of those steps.


#5

Is your computer possibly going to sleep?


#6

All my equipment is turned off overnight, except for the router which the drive is connected directly to.


#7

I tried that and although, yes, it does allow the drive to connect again, it seems to be too unstable to actually get access to it. Web browsing takes forever, but the My Cloud pc app detects the drive quite quickly. I rebooted it again and I’m currently running a full system diagnostic test on it.


#8

What do you mean by access but unstable? When you reboot how long does it stay accessible? Does it always have the same IP address?


#9

I mean “unstable” as in I’m not getting error messages when trying to access shares, or web browsing to the dashboard, but I still can’t access them. The dashboard app also finds the drive OK. It takes a reboot to get full functionality back.

As for times, well I rebooted mid morning yesterday and then it disconnected again around 12.45am this morning. That’s when I tried stopping the samba service. I also have it configured with a static ip address, which is reserved on my router.

I just checked and the diagnostic test is still only 90% done, and the drive is still connected.


#10

Since your device has not disconnected while it is doing the full test. I would google router heartbeat signal. It could be that some device it trying to talk to the My Cloud while it is a sleep. Because the My Cloud needs to wake up it responds to slow. Which can cause the disconnect. I know my My cloud sleeps a lot and never gets disconnected.
What is the router model?


#11

I turned off the sleep option in the dashboard before running the test. And shortly after checking it gave an error message that the data couldn’t be found and stopped. I’m out of the house now for a few hours so will check it when I get back again.


#12

It may still be a heartbeat issue; the router may be being rather hasty in deciding it can no longer see the MyCloud, even if the MyCloud is ‘awake’. Sometimes it is busy doing stuff (indexing, re-scanning media libraries, checking for firmware upgrades, doing its regular 3am thing…


#13

So it could be to do with my router? If so then I’m gonna have a problem as my router is a proprietary model from my isp and has little or no configurable settings.


#14

You could try putting a switch between the router and the other devices.


#15

I had it connected to a My Net 8 port switch and moved it over to the router when the problem started. I probably should have said that at the start.


#16

Let me guess; is it an at&t uverse router…?

Yes, that would have helped…

“I did something, and now no longer works. I wonder if what I did has broken something? Perhaps I should put it back and see if it fixes the problem…”


#17

No it’s not at&t. I live in Ireland, not the US. It’s a Virgin Media branded Arris cable modem router, running custom Virgin Media software.

And as I was having the issues while it was connected to the switch, and before I moved it to the router, why on earth would I think moving it back to the switch again to see if that resolved the issues? It makes no logical sense.


#18

You had not mentioned the switch prior to his suggesting it.


#19

Read it again. It implies that by moving the drive from the switch to the router, it may have broken something, even though he knows that it was broken beforehand. So whether I mentioned it from the outset or not, is a moot point.