My Book World Edition - Straming issues since update 01.02.14 with MioNet

Hi, i’m new to this forum. I’ve had a good look for any answers/help with the above but couldn’t find anything. I have been in touch with WD support but they were very unhelpful.

Bascally i’ve updated the Firmware version of my World Book Edition to 01.02.14 with MioNet and since this update the NAS drive cannot stream video seamlessly without having to load 10 seconds worth of video, then play that 10 seconds, then load 10 seconds, etc. etc. It just cannot play a video without having to load it. I am playing .MTS files which can be quite large but the problem is the same regardless of the video size. It also takes ages even loading photo’s. I’ve got my NAS drive connected to a homeplug and then connected to my Samsung 46" D7000. I’ve tried connecting the NAS drive directly to the TV and the same thing happens soI would assume it’s not bandwidth.

Before the update it worked perfectly. WD support were very unhelpful (after initially taking weeks to reply) as the advised that I could re-load the previous firmware version, but they were unable to provide me with this version…

Unfortunately, when I updated the firmware i didn’t take a back up copy. Unless one is created automatically? Sorry i’m not very techy when it comes to the nitty gritty.

If anyone could advise a) would the previous version be saved on my NAS drive and/or b) can anyone point me in the direction of the previous version of the Firmware it would be very much appreciated.

Many thanks and happy New Year.



Have you tried resetting your router or the my book?