My Book World Edition II External Drive "Not Responding" When Clicking To Open The File


#1
Having a very odd problem. Installed the My Book World Edition II external 
hard drive to my Windows Vista about a year or 2 ago, and it was working fine 
until recently.

I tried to create a new folder to add files from iTunes, and all of a sudden 
it locked up and gave me the "Not Responding" error. I closed the program, 
and then tried to open it again, but the same thing happened. Now every time 
when I click on the icon to open it, it starts hanging/locking up and "Not 
Responding".  

I disconnected it and plugged into a Windows XP computer to see if I would 
get the same message (to check if it was the external hard drive or USB cord 
causing the problem), but it worked fine on that computer. I clicked on it, 
and the file opened up right away.

When I connected it back to the Windows Vista computer, and clicked on the 
My Book file, it again locked up and gave the "Not Responding" error. Also 
did a disk check on that drive, worked after that for a few minutes, and then 
the program locked up and stopped responding again. Virus program didn't 
detect anything, and all devices are working properly. 

At this point I'm guessing it can't be the My Book external hard drive or 
the USB cord, since it worked fine on the XP computer. Also tried connecting to a different USB port, changing the USB cord, and using a Firewire cord, but still kept getting the "Not Responding" error. Any ideas on what this 
could be and what I can do?

Thanks, 
Nyc79