My book white light locking up

For the first few days I had no problems upload 700gb to the unit. But now every so often when I am uploading the unit locks and the only way is to power it off at the mains. The unit was updated with latest firmware on day one which was 5 days ago. Today I tried to upload  35 gb 104 files it managed 50 then locked up. :-(  Anyone have any ideas thanking you in advance M.

I have just bought a 1Tb My Book world edition II. I am having exactly the same problem on Vista and I have read others have had this same problem on Windows 7. This is really annoying. I actually can’t use the drive and I’ve only had it for 5 days.

Mine is a 2tb and I am using windows 7. At this moment I trying to upload from one of my laptops with xp on it. I run an upload to the unit for 7 hours and it did not fall over in that time. I then deleted the files and now I am uploading again this time though a wired connection with same laptop. So far no problems 3 hours and 63 gig of mp3 files. After this has finished I am going to try one of my window 7 machine to see if it screws up. M

At the moment the unit running ok I uploaded 63gb from my windows 7 laptop that was ok, then I uploaded 80gb of video files from my windows 7 desktop computer and that worked ok. I am waiting for a reply from WD to see if they have any answers. M

WD could not give me an answer, but seems that unit is working ok time will tell. M

Look below this is not solved.

I have just purchased the My Book World Edition II 2TB and connected it up to my Wireless Router then onto my laptop using Windows 7 (64 bit), and I have been having the exact same problem.

I would connect the MBWE II and it would work for some time, but then I would start doing some downloading, surfing the net, transferring files, extracting files, and/or other general work.

Suddenly I would have no connection, my laptop would not recognise the MBWE II, I would pull it all apart and start again, and just as suddenly it would start working again.

I am finding the MBWE II like many other Western Digital products are not suited for multi-tasking, and will crash at a drop of a hat. I had a WD Media Player that would not play, or crashed if I did anything else on the laptop (even automatic updating of any program on the laptop).

I have the same issue with the 2TB model. It was a warranty job, because the 500GB did the same thing. This is networked with 7 machines in the office. All on XP except for one new machine on windows 7. The older 500GB drive only had XP machines on it. None of them have any sort of WD software installed. The machines only access the drive through a mapped network drive , and only backup once a day.

The problem is back again. This seems to be the same as Drive becomes un-accessible after short use thread. Which has been running for a year now. It seems like most big companies just keep stuffing it under the mat and hope it goes away, If you ask question on a helpdesk you get the same question every time ie- what firewall, av, etc. Are these tech people for real or what? Maybe we might an answer one day?

I have found that the drive freezing is due to over heating. I put a small desk fan on mine turned to low speed, and it transferred 1.4tb of data in one continuous transfer. If you can manage to put a usb powered fan on your case that should solve your problem for good.

I thought my problems had gone away when I updated to the latest firmware 1.02.06 but when I tried to upload 7.5 gig of files it locked up so the problem is still there. This is off a Windows 7 system. I have yet to try the same upload from a XP machine, as I use mainly windows 7 this does not help. Come on WD get your finger out and sort this problem out. M

Update I tried the same file again from both an xp and a windows 7 computer, twice from each this time no problems. I going to leave for a few days and try again. If this is an over heating problem it should have crash out this as it had only been switch and on again after it locked up. So we shall see if leaving it running for a few days and uploading again has the same effect? M

I found a software solution for the same problem

Hope this helps :wink:

1 Like

@hurtware Thanks For the information. I have tried the solution in the above link and  time will tell. Update I have just upload 53Gb no problem will make the solution permenent next time I restart the unit. Thanks hurtware M