My Book Studio II 1TB eInk display and wd smartware problem


#1

Hello there. Just purchased that drive, but have 2 problems

  1. The display always shows VIDEOS 09 like a static image. No way to change it. After i install wd smartware, it prompts me a windows where i have to put the label, registration and password in.

   a) Wrote in the label and pressed the button. Nothing changes on display.

   b) Wrote in the registration, name, surname, email, pressed register and error appears on the top saying could not be registered. Verify the data etc… But it’s all correct!

  1. After opening the main program (where you make backups and setup for the drive) but it hangs every 3 seconds (Mac loading icon appears). And i tried to change the label from there too but still nothing. THe program version is 1.1.1.4. 

What am i doing wrong?


#2

up…


#3

I have the same problem! The screen changed once to display the label I wanted but now it will not update the remaining space on the label. I have tried the same things as svkrzn but had no luck. i also have smartware version 1.1.1.4.


#4

Same… can’t revise the label.   Version 1.1.1.4


#5

I had the same issue and was about to get the HDD back to the store to return it. However, once I have uninstalled the SmartWare app (dragged it from Applicaiton Folder to Trash) and tried installing it back from Virtual CD, it worked again. Please try and do that as there seems to clear up the label issue and now everything works fine.

I struggled with it for a few hours yesterday so I hope this will save some headache for someone out there. Cheers.