My Book Studio Encryption Keys


#1

Hi,

Does anyone know, where the encyrpytion keys are saved? Are they on the board in the casing in the flash?

The problem I have here:

I’ve tried to update the firmware which doesn’t work ( had no error, restarted the drive but it wasn’t recognized anymore). The flash is empty, I can connect to it and it gives me the Oxford Semi. as device name (tried their Oxford Uploader to reflash the bios without any luck).

I’ve now got another MyBook Studio and put the old drive in the new case. It doesn’t work, so I’ve asked myself, where the encryption keys are saved to transfer them to the new board.

Or does anyone had luck reflashing the board? Tried it with windows/mac os. WD pulled the firmware from their site yesterday, you can’t download it anymore (mac version).

Any help here? WD support is not really helping here. But I think, doing hardware encryption without telling the costumer and without setting a password doesn’t make any sense, just trouble…

Kind Regards, Ingo


#2

The encryption is handeled by the circuit board. Even though you have a Mac try doing  the firmware update on Windows that was a problem a while ago and that was the solution.

Joe


#3

Hi,

have tried the Firmware Update on Windows. The Updater crashes when flashing the drive. Do you have an older firmware with which I could try the update? I have the latest one from the WD website.

Thanks!

Kind Regards!


#4

Look down in Documentation and there is a step by step to recover or repair damaged partitions.

Joe


#5

Hi,

thanks for your help, but I can’t find the old firmware. The problem also is, that the partition itself is not damaged, it’s the firmware that was not flashed right.

Kind Reagrds!