My Book Studio ejects improperly when iMac goes to sleep

2015 iMac, Sierra 10.12.4

Hello, thank you for reading this long post.

My issue is when I wake my iMac from sleep I find my drive has ejected improperly. The issue is intermittent. My iMac has 2 users accounts, and I am pretty sure it is only happening to one of the accounts? Typically if I log out the issue won’t happen.

Another issue with the iMac is if I leave my iMac logged in only to my personal account, not the other account, sometimes, it will freeze shortly after waking from sleep. Both of these signs point to an issue with my account? Log in items? The freezing and ejecting do not happen simultaneously.

This iMac was recently purchased and the user account was transferred from my MacBook Pro using Migration Assistant via a Thunderbolt 2 cable. That MacBook has no issues.

I have two external 3 TB Western Digital My Book Studio USB 3 drives plugged into my 5k iMac. They are plugged directly into the iMac, not into a hub. Only 1 of the 2 drives has this issue.

I have tried different USB ports on the back of the iMac, issue persists.

I have reset SMC and NVRAM, issue persists.

Tried unchecking “Put hard disk asleep when possible.” in Energy Saver preferences, issue persists.

I have updated the firmware of the drives, issue persists.

I have repaired the drives, erased and reformatted, issue persists.

I even booted to Recovery and reinstalled macOS, issue persists.

I have sent the drives into WD and received two new replacement drives with new USB cables and power adapters, issue persists. What are the chances of these two replacement drives also having the same issue?

Tried removing preventing Spotlight from cataloging the drive’s contents, issue persists.

Please help, AppleCare and WD Tech support have not solved helped me with this issue.

Hi, based on the description you have provided and the troubleshooting steps you’ve taken, it sounds as if the issue is coming from the iMac account. You mentioned you have the MacBook Pro and that it has no issues, have you tried the My Book Studio on that computer to see if the same issue happens? You can also try to create a new administrator account.

So unfortunately it now happens to another account. So I have not narrowed it to my account anymore. It also only happens with my data drive, not the second drive that is for Time Machine.

I have two My Book Studio drives. They were both doing it. They were both updated to the latest firmware and I did lots of troubleshooting before WD issued replacements through an RMA. I received my replacements though and now only 1 of the two drives ejects. I noticed a difference in their serial numbers.

These serial numbers are for my two previous drives that have been replaced under RMAs, [Deleted-Privacy] (RMA: [Deleted-Privacy]) and [Deleted-Privacy] (RMA: [Deleted-Privacy]).

These are the serial numbers for my two new drives I received through the RMAs: [Deleted-Privacy] and [Deleted-Privacy].

The new problem drive serial begins with WMC, the previous drives both gave me this issue and their serials begin with WMC.

My one drive that is not giving me this issue serial number begin with WCC. What is the difference between these these two serial numbers? If my issue does not persists with the drive that begins with serial WCC I would like another RMA replacement for the problem drive I received beginning with WMC.

Please note that this is a user to user community. For specific questions about the serial number on WD drives, I’ll recommend you to write to WD support.

Thank you. I will do that.