My Book stopped working


#1

My external My Book drive lites up and is running but not being recognized.  It was working fine yesterday but today all that is lit up is one of the LED’s at the bottom.  I can feel it running.  Hope I haven’t lost everything on it as I haven’t got everything backed up yet.  Any way to get it recognized again at least to get stuff off of it.

Thanks

Russ


#2

Try changeing the data cable and connecting the power adapter directly to a wall outlet.

What os are you running windows or mac?


#3

I just had this happen to me yesterday, I hear the notice sound that a USB was plugged in as well as the I can feel the unit running, but my computer is not recognizing it.  I have Win7 Pro 64bit.


#4

If it sounds like its unplugging by itself I would suggest another data cable keep the device manager screen open and watch the universal serial bus controlllers to verify connections appearing and dissapearing most likely its the data cable


#5

Thank you Lawrence for your quick reply.  I have tried 3 different cables, two from WD external drives and one from another company.  I even tried a fourth from a camera to no avail.  The light is on and the unit is running, but still no recognition.


#6

Please read my post here… I am sure you’ll find your answer.

http://community.wdc.com/t5/My-Passport-for-PC/FIX-For-Drive-disappearance-issue-on-Vista-amp-Win7-XP-Scenario/td-p/125674


#7

I’m running Windows XP SP2


#8

I think your My Book USB>SATA interface or SATA drive itself is failing. You can check your drive directly on SATA interface, if you manage to open My Book enclosure. These drives can directly plug in to any SATA port on Desktop PC or to an eSATA port.


#9

I don’t know about RussBG, but I RMA’d my ‘Passport Essential’ as I could not get it to work.  I thank you guys for your replies.