My Book Office Edition Activity Light Always Moving

I have the  My Book Office Edition, and have used it with no troubles for quite a while now.

Recently, I reset my laptop to factory defaults, re-installing all the software.  I no longer have the original software for the WD MyBook Office, and can not find the ORIGINAL software that came loaded on it. Yes, I know there is an updated version on the legacy external support section, but I do NOT want the updated version, I wanted the OLD, ORIGINAL software which worked perfectly.

THE PROBLEM: Since I reinstalled and reset my laptop to factory defaults, my WD MyBook’s activity light never ever stops moving.  The drive is active, 100% of the time, and never ever rests. I can hear it moving as if it were accessing a file, or the way it sounds when moving a large file or any other normal activity.  It is acting different since I lost the original software.  I installed the new software version, and that does nothing for me.  The light never stops moving regardless if I run the software, or not. I’ve tried uninstalling it, but that has made no difference.

I am using windows Vista, if that helps anyone assist me.  The drive has 55% space available. No programs are running that need to access it, as it is used only to backup my data files at the end of the day.  My antivirus isnt running a scan or anything. Pressing the button in the back no longer turns the drive on and off. The activity bar flashes, then goes right back to flashing, up and down endlessly.

The only other thing that is different that I can think of is that for some reason Windows insists on using Autorun instead of loading it as a drive. (Meaning: when the laptop starts, it uses the “AutoPlay” option to “Open the folder to view files in Windows Explorer”) – this was never an issue before I reset my laptop.  Maybe it has something to do with not having the original files that were on the drive when it was new.

No amount of Google searching has led me to this problem’s resolution, NOR can I locate the original files.  Yes, I am a little fixated on the original files since, for some reason, I recall those worked for me and the updated ones did not work well for me.

Any help would be appreciated.  And if anyone has the 100% original files backed up somewhere and would like to share, that would be awesome.


This is a very specific situation, and indeed the original files are no longer available on WD’s site as they have been updated for compatibility purposes. Hopefully the files will be provided by a board member keeping an archive.


Yeah, I have my fingers crossed.

As it is now, I have to unplug the drive while not using it. Otherwise it runs so much it is like a miniature heater on my desk. The fan runs all the time to keep it cool since the drive never ever stops.

If anyone knows WHY it is always being accessed, or why the activity light is always running, that would help a lot as well.


What if you try to remove the Windows Indexing Service for USB devices? Although WD does not feature a dedicated tutorial for this procedure as it is not supported, I am sure there are several guides available online.


I will research that and see if it works. For now, I keep the drive unplugged when I am not actively archiving some files. So, it only gets about 5 minutes use per day.  Hopefully your suggestion works.  Thanks!

My pleasure.