My Book not seen when needed most!

I bought a “My Book” as insurance in case my older “Samsung Story” failed. My Book is recognised as a drive by my destop PC (running Windows 7.1) and backups work. I use Macrium Reflect and Acronis True Image for disc images. So far so good.

Disc images are only of any value, of course, if they can be restored in the event that disaster strikes so I did a test. I saved disc images using the programmes above to My Book. I repeated the process on my older Samsung Story. I then used the Recovery Discs in each case to find out whether I could restore the images to my PC.

While the images saved on my Samsung Story showed up for restore, the My Book did not even appear as an available device. In Macrium the recovery disk allows access to the command prompt. I gave “diskpart” a go but My Book did not show up as an available volume.

I tried a couple more USB ports and unplugged the Samsung Story but still no joy.

For me the My Book is not fit for purpose if my Recovery Programmes can’t access the disc to restore system images. Has anyone else experienced this problem and found a solution please ?


I have never tried this.
I use WD Smartware for my backups.

Lets see if another user has tried this and can share some ideas with us.