My Book not recognized, cannot install driver


#1

I have a MyBook external drive and when I plug it is, it’s not being recognized under disk management or My Computer. However, when I plug it in, it prompts the “new hardware” message and ask me to install it, but I’m not able to as it says it cannot find the necessary software. The HDD also shows up in the device manager, as “USB Device” with the yellow exclamation point. I’ve tried updating the driver from here too, but I get the same error.

I’ve tried all of the troubleshooting suggestions in the FAQ but nothing has worked. Is there anything else I can do or is the drive completely shot? There’s some data I would really like to get off of it.

Thanks!

Edit: Also, I’m on Windows XP if it matters any.


#2

Try a different USB port.  You don’t need the drivers to use the disk as a simple mass storage device under xp, but you will get an annoying pop-up each time you boot up.


#3

Is your XP up to date with SP3? iIf not try updating that and see is it helps.

Joe