My Book Mac - light on, no love


I tried plugging in my My Book Mac hard drive. i am not using an official WD power supply, but the light on the front of the hard drive is on when i plug my power packet in. so it seems that power is actually going to the thing. but no love on the other side; it doesnt turn up on the dock and the drive doesnt seem to spin either. is it possibe that i have fried the hard drive? pressing the on/off button doesnt seem to work… i hold it on, i press it… nothing happens.

also, is it possible to reset the hard drive? push a paper clip into the side of it or something?

thanks very much. if you need pics please let me know. 

same thing happened to me. local repair services won’t be able to fix it saying the connectors inside are detached… not sure what to do. help please!

I have a similar problem.  When I try to read the disk, it gives me the prompt…“Initialize…” (scared to press that one), “Ignore” or “cancel”

I have tried on two different Mac’s…same error.  I am afraid to go any further.  Any ideas?  

The drive turns on and the bottom power button is lit.  No other lights.  What to do?