My Book Live firmware cannot be updated


Current version is MyBookLive  01.05.07. I’ve enable the Auto Update.

I found there is a new fireware provided to solve the Mac Lion issue. And I tried the get it patched.

Finally, it cannot be updated either by “Check for Update” nor by “Update from file”. If I select “Check for update”, the dialog “Please wait” will last forever. And If I select “Update from file”, after locate the local downloaded firmware file, it stucked in “Importing File” dialog.

I used IE9, so, I swithed to firefox 6.0, still cannot work. It seems not a browser issue.

One more interesting thing is, if I want to turn off “Auto Update”, there will be a waiting dialog last forever. But turning off disk’s Energy Saver still works.

Any ideas for the resolution?

Best Regards,


It solved now. The key is, auto update should be turn off before manual update.

I used IE 9.0 to turn off the “Auto Update” but failed. And the first time when I tried firefox to turn off it has the same issue. I noticed that there are multi-browsers connect to this device at the same time. So, I close all the connections. After several hours, I used the firefox to turn the auto update off and succeeded.

It may depends on luck to solve such issue. Hope the update will be more stable next time.

Best Regards,