My Book Live doesn't work after reboot anymore


I used my my book with the normal firmware etc. and Transmission which I installed with apt-get over ssh.

2 Weeks ago I updated the firmware of the NAS and I had to reinstall the Transmission again. After that the drive worked properly but the web ui didn’t work correctly anymore. Only the start page worked. Therefore I thought a reboot would help.

The drive booted up normally but does not appear in the network anymore since. The LED on the front turns to solid green (not flashing) and also the network connection shows only the orange light and not the green traffic light. The NAS does also not appear in the routing table of the router. I also tried to connect the drive directly to my macbook (with network sharing on) but also then the drive does not allocate any IP address. 

The reset button at the back does not seem to work either. Pressing the button has no effect at all.

Any suggestions ?

I am having exactly thesame issue…sounds like an hopeless situation am afraid…I am more worried about the top secret files in my MBL if I have to send it off.

I do hope a techy or smarter guy that knows of a possible solution can help. Last thing I want to do is send it to data recovery of WD appaling customer service unit

I don’t mind to send the disk to WD but I’m waiting for their reply already a couple of days.

But I don’t think they will check your data nor touch it. Mostly they only have to reinstall the firmware. 

I’m pretty sure this would do the trick on my device. But since the only connector is the ethernet cable and I don’t get an IP, I can not access the drive and update the firmeware. Strange thing is that the reset button does not do anything.

You could also try to unbrick the disk yourself. But you need a computer where you can connect the HD, which I don’t have here at the moment. Also warranty will be gone if you do this and quite time consuming.

Hi There,

I have the exact same problem!

Please let me know if you find a solution - will be much appreciated.

I  my case the MBL LED goes from Solid Blue to yellow (after disconnecting and reconnecting power) and then stays Yellow.

It’s been a steady Yellow for hours now - does the reset button on the back of the MBL actually do anything?


WD wrote me back that I should reboot or reset my router. Standard answer from them I guess. Unfortunatley this does not solve the problem of course. I responded and I’m waiting since. If I don’t get an answer soon, I will try to debrick it myself. 

Did you get an answer ?? im having a similar problem, after installing transmission and worked well, but after restart the routet now i cant access it, it doesnt appear on my router active connections so i think it isnt getting an ip address