My Book Live cannot use WD Sync, Wd3go or any other software

Hi,
I have a WD Mybooklive 2T and all is configured and working.
The disk is found and accessible on the home network, no problem here.
Port fwd opened in the router and working… but…

The problem is:

  1. when I try to use Wd sync software on my MAC it doesnt detect the disk
  2. When I try t use “My Cloud” app on the iphone it detects the disk, I select the user, insert the password but then says “No Network”
  3. When I login into mycloud.com it asks me for a 9-digit code which my disk doesn’t have.

Basically I can use it as a home network disk but none of the remote access functionalities.
Has anyone faced this?
It is frustrating!

Hi pramses ,

1.Unfortunately, WD Sync does not support My Book Live.
2. May be you should check on the dashboard whether the cloud access is enabled or not. If not, then you can refer to the link below:

https://support.wdc.com/knowledgebase/answer.aspx?ID=13172

In order to login to MyCloud.com, please check the link below:

Hi

All is installed, remote access created and working:

When I try to log in to mycloud it asks me for a 9-digit code right after login? I can’t find it anywhere! It also doesn’t let me navigate anywhere else…

When I try to use the app, gives me a “No Internet” message… when I have 4G and everything else working. Btw, the app sees that I have remote access to mybooklive and asks to choose user, but then I can’t access anything else.

Can anyone help??
Am I alone here?

Hi pramses,

May be you can try to use this URL : “files.mycloud.com”.

Ok, this worked! I can now access my files remotely through the web. on the browser.

Now, just need to access on the ios app My cloud. I still get “no internet”
Can it be a certificate issue as well…?

Screenshot bellow

Problem solved!

The APP doesn’t work when you have too many “shares”. I had around 8, even if 4 were empty. I reduced to public+2 and now the app works fine.

Also noticed that the Dashboard runs much faster.

I can now access remotely through the app and web.

Problems I still can’t figure out:

  • Web interface is read-only (for private Shares)
  • Web interface doesn’t have “copy link” functionality
  • Still don’t understand what is difference between: mycloud.com and files.mycloud.com (too confusing all this)
  • Also, WD Sync doesn’t work with this model (pity but understandable due to old hardware)

Would be nice to have a Chat support.
This took me a week to figure out and had to deal on my own…

Greetings!