My Book Live 3TB - Not accessible any longer

MBL 3 TB (just 2+ months old) is no longer recognized by my computer (Vista OS) wirelessly. The drive has a lot of data already backed up. THIS IS NOT A FIRST TIME DISCOVERY PROBLEM. EVERYTHING WAS WORKING FINE TILL LAST WEEK - THE PROBLEM STARTED 3-4 DAYS AGO - or at least that is when I noticed it. 

The drive is connected to my router (Ethernet) and the wireless router (Linksys E4200) is working fine and all my computers are connected wirelessly. The router is connected to the Samsung Smart TV (wired connection) and I can access photos/videos and listen to music in the MBL drive through TwonkyMedia - no problems there. Other information -

  1. Tried rebooting my computer and MBL (power off reboot) a couple of times
  2. When powered up and wired to the router, the drive has solid green led in the front (never blinks; never goes to sleep - i.e. turns blue), blinking green led in the back (top) and solid green led in the back (bottom)
  3. The laptop OS is Vista
  4. Laptop firewall is off
  5. No changes made to the router settings

Then I tried connecting my laptop (Vista OS) directly to the MBL drive. Tried with both Firewall on and off.

  1. A connection titled “Unidentified Connection” appears in the network connection list’
  2. The led at the back of the drive (bottom led) stays solid amber. The activity led blinks
  3. Mybooklive is not listed if I expand ‘Network’. Hence am not able to map it as a drive

In short I have all my data in the drive (I am able to confirm it by accessing the same through my TV’s TwonkyMedia connection) but there is no way I can access the data through my computer. Please reply if you need more information or have a solution. Many thanks

What if you ping it? Click on start> type CMD on the search bar> type PING theIPaddressofyourMBLorthenameofyourMBL and see if the computer comes back with an IP response, then try to access that IP by typing \thatIpaddress on the search bar when you click on start.

Check if something has changed on the computer, like the WORKGROUP name and check your router as well, when you access your router’s configuration page it should display the MAC address of the MBL, why is physically printed to the MBL as well (Unique).

1 Like

Thanks for the reply.

No - pinging does not get me any response.  I had tried that before.

As far as I know, nothing has changed on my computer or my router. 

About checking on the router, I have a Cisco E4200 router.  Would you be able to tell me where I should look to see the details of the MBL hard drive?  Thanks in advance!



Further to my previous post, could somebody please answer these questions as well? 

  1. If the drive is not accessible through a computer (as seems to be the case), how come I can easily access it through Twonky Media and see the photos/videos and listen to music in the drive?

2. Is there any way to retrieve data through the TwonkyMedia connection?
3.  If the drive cannot be revived, how do I get my data back?  Or at the very least destroy the data before sending it back to WD guys?

Any help will be much appreciated.  Please …

Thanks for your patience.


Recovering your data from such a situation required opening up the MyBook Live’s case, using an SATA to USB bridge and if you’re not using Linux, software like WinHEX (which if commercial but there may be freeware stuff about) to access the drive’s data partition and recover your data and I think I found such a freeware file system driver…

Also found another . . .

Thanks.  Being new to this situation, some more basic questions -

  1. The SATA to USB bridge is a connector, right?  I assume it is available BestBuy and other stores.  The SATA end goes into the Mybooklive drive (after I open it up) and the USB end goes into the usb port of my laptop computer

  2. Since the two laptops i have are running on Windows 7 and Windows Vista, I have to download the additional Linux reader software.  Oher than that, no change to the laptop OS, I presume

3.  Finally, anything else I need to be aware of?

Thanks for your patience!