My book live 2tb wired connection problem

Hi all,

I can connect to shared folders only when my pc is wireless connected to the router.

When I connect my pc to the router with the ethernet cable, there is no way to see/map/surf folders on NAS.

The same problem appear both on W7 and my girlfriend’s macbook.

Can anybody help me?

Can you describe what happens when you try to connect?

Any error message or screen shot will help

do you have the same DNS address assigned in the IPv4 settings of your wireless and wired network devices?

Does not happen anything when I try to open Public folder from WD quick view utility directly, and when I try to map the folder or open it from a shortcut it ask me a psw, but I have not a psw set on my device.

I had the same result on a different router with different PCs.

if you mean the same DNS Server adress both in ethernet and wireless yes, my router works as DNS serves as well (and I can’t set different DNS for ethernet and wireless).

Nothing change when I connect MBL directly to my PC…
Moreover, I tried to view files from browser UI and “my documents” folder (on my pc) was opened…

try putting both the wirless adapter IPv4 DNS and the wired NIC IPv4 DNS to just to see if that resolves the issue.

i had this problem the other day, i simply disabled my nic and then re-enabled it through the diagnose problem dialogue

in windows 7 to update everything, it worked fine after that.

1 Like

i just had the same problem, i wouldn’t see my drive anywhere. i connected my drive directly to my pc deleted my network card and restored by itself…now its all good thanks