My Book Live 2Tb, Facebook query, auto upload

Hey, after posting my query/issue on WD facebook page I was requested to post here. 

Please see screen shot below. 

If you need any more info than what ive already posted please contact me. Looking forward to your response.


What firmware are you running on the device?

Have you tried resetting the device back to factory defaults?

That’s wd photos or wd2go/myclod the one you’re using?

Safepoint won’t work with a USB drive unless it can be assigned network permissions via SMB protocols.

Help4all, gs3 running standard jellybean 4.1.2
Didnt want to have to reset. But after speaking to a member of wd phone support he suggested un install and reinstall. This didnt work. So I decided to clean the phone of all photos videos(transferred to computer). Un installed app again, turned off phone.back on again reinstalled app and took a few pics and vids. And it works now. Uploads all of them. One gripe I have with the app as mentioned to the fella i spoke with was to change the position of the ongoing uploads in notification bar, currenlty when uploading and completed its displalayed as in pic attached.

I would like to see it moved/adjusted like when you upload photos to facebook or google drive, shows its ongoing then moves to completed when in the two photos below.

Hey PizzaMatrix,

Its safepoint on mybooklive, not related to the app. After speaking with tech phone support he said I would need another device with the same storage capacity as what I have to create a safe point. Basically backing everything thing up. I thought safepoint was something like Microsofts Restore Point, where it takes a snapshot of everything and allows you to revert to that point in time where everything worked before. Looks lime I was wrong. Thanks for the advce anyway. Bu I dont know what SMB protocos are?