My Book formate to FAT32 with WD Fat32 Formatter fails

When I try to install the WD FAT32 Formatter I get a failure notice fat32formatter problem mit windows
that does not help me any further. What can I do. I tried different ways an programms - and nothing works.

Windows 10, Microsoft Surface 3 pro - Please help.

Hello!

Have you tried to format through Disk Management directly?

Do you have a particular reason to format it in FAT32? ExFat is a better format overall, depending on what use you need.

Yes - I did, but my system offers only exFat - not Fat32. Fat 32 ist required for my fritzbox and the playstation.


And - no: exFat does not work with both of the devices - I already tried. On the other Hand I have the proof, that it works with fat 32 very well.
My other attempts:

  • The Free Partition Manager didn*t offer FAT32 as well.
  • by using the Windows mask and typing “format /FS:FAT32 D:” I didn’t succeed, because the program asked me for a volume label for the drive - and everything I wrote failed.

Maybe you can try other software to format it, usually a Google search will give you some good free software for this.

Alternatively try using Acronys.

Ok - Thanks a lot for the help. After loading a few faulty versions of Acronis installer I succeed formatting the disc to FAT32 - but … still a BUT: Neigther FritzBox nor the Yamaha sound system comunicate with the myBook … aaarrrgggghhhh
I already learnt, that fritz box needs an external power supply - thats why I bought myBook. My quite old 500MB WD-Disk works well with the box - formatted by an easypeasy fat32formatter. Maybe the mybook is too big?.