My book Essentials 2TB - can't access data after power interuption

The power went out for about 30sec and now the data won’t show up on the drive. I checked the properties of the drive and the files are there but won’t show up when I access the drive. Is there any software that will fix this issue. Also the drive doesn’t show up under disk management.

More info:

When I first accessed the system not knowing there was an issue I could see the data in a window I had open previously before the brief power loss but when I attempted to move some data to another location I got the following error

Windows - Delayed Write failed

Windows was unable to save all the data for the file F:$BitMap. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try and save the file elsewhere.

One thing has changed, the drive now shows up under disk management but states the following

Disk 1 - Unknown - Unreadable  and there’s a small red circle with a white line through it over the drive icon.

Under my computer the drive is listed and the size is correct and the used space(data) is correct but when I open the drive it’s empty. I haven’t tried to copy any data to the drive and I won’t until I’m sure there’s nothing I can do to recover the files.

It probably got corrupted some people have had sucess with Testdisk


I tried testdisk and even though the program can see the drive and reports it as a 2000GB disk when I search for a partition it doesn’t find any and as it’s scanning it’s also getting read errors. I tried using testdisk to fix the MBR and it failed. Not sure what to try next.