My Book Essentials 1130 External Hard drive - error?

Hello, I am looking to see if anyone can help me? I have run into an issue that I hope can be solved.

I have had this external hard drive for a while now, few years actually. I have never had any issues with using it to keep a back up of important documents and photos. I was placing photos on the external hard drive tonight, when it all of a sudden froze and when it unfroze my pc no longer recognized it (it didn’t show up in the my computer explorer - if that makes sense). I went opened WD SmartWare program, it shows that the hard drive is connected. However, it says no partition can be found.

I did download and run the Western Digital Data LifeGuard Diagnostics program. In the program, the hard drive shows up but where it shows the SMART Status it showed a ?, but when I ran the smart test it said it passed.

Now another thing I noticed was when I unplug the hard drive from my laptop and then plug it back in it’ll show up in the explorer list for a split second then disappear.

I am really hoping I have a way to save all my important files on my external hard drive. My dad passed away a few years ago and I have pictures of him on this external hard drive and do not want to lose them. :confused:

Any help with my situation would be highly appreciated.


PS: I am new to this community, if I happen to post this in the wrong section. I apologize in advance!


Based on the information you have provided I believe the partition is corrupted.

You may try using a data recovery software in order to recover your files and if this does not work then you should contact a data recovery company.