My Book Essential


I was working with my Book Essential (moving files between folders, and copying a big file from pc disk). While copying files, my computer got stressed didn’t respond for a long time until I closed everything with task manager (under Win 7) and restarted my computer. Then, my external drive is not responding anymore, it starts (and has a white switching light, as it is in “pause”), but windows explorer does not show it in the Hard disk drives place. Still, when I connect the disk to the computer it recognizes new hardware installed, and if I click on “Safely remove Hardware and eject media”, there is the option to eject “My book 1110”.

Exploring I have found a WD application that allows to perform a quick analysis, a more complex analysis, write 0’s (formatting its containing) and revisiting last logs. I can’t remember the name of the application, but trying to perform quick analysis or complex analysis the result was: “too many sector errors when accesing the disk” or something similar, when the analysis is at 0%.

I have attached the external disk to my TV, it recognizes it, the external disk performs that “working sound” due to the fan cooling, but then it appears in the tv “disk has no available data”. When trying the external drive in a different usb port, the result is the same.

I have tried to update the external disk firmware (it appears to be something like 1.4xxx or 1.6xxx, I  can’t remember) to 2.0.18, but then it shows: “Erase My Book Essential, too many attempts”. At this moment I’m not willing to erase my data at all :(, so it is not an option.

I have also downloaded testdisk and analysing the disk, but it is at 6% after half an hour or more, so I won’t know the result until tomorrow I’m afraid…

When I go to Disk Management, I’m asked to initialize disk, but then it says “The media is write protected”, and the disk appears as Disk1, unknown, not initialized and unallocated. In the properties, the device status is "working properly. Also Quick removal is selected, and current driver is from 2006 but when I click on update driver and “search automatically”, it says it is the most recent version available.

I’m somewhat afraid I have lost my personal data, but I want to try every possible way before formatting it. Can you please help me giving advice?

Thanks in advance :slight_smile:

Sorry for the auto-reply.

Today I have tried easy recovery without success (I/O error for EACH sector :s), and finally I tried to update the firmware, and when I was asked to erase all data, deleting the unit, I clicked yes. But then appears a pop-up informing that the application detected an unexpected error and closes, without formating.

I’m pretty sure I have lost all data, but there is a chance to format the disk and use it again?