My Book Essential USB 3.0/2.0 2 Tb


#1

I just purchased the My Book Essential USB 3.0/2.0 2 Tb external hard drive and I am using Windows 7 64 bit.  I have noticed that when I plug it in, the WD smartware CD autoplay does not appear and there is no Virtual CD under the “Devices with Removable Storage” section.  There is just one My Book Drive under “Hard Disk Drives”, and this drive includes the WD Smartware, Extras and User Manuals Folders.  With my old My Book Essential USB 2.0 1.5 Tb external hard drive, the WD Smartware Pop Up and Virtual CD Drive appears, and when you click on the drive under “Hard Disk Drives”, no folders appeared (when it was brand new).

Is this behaviour normal for my new drive, or do I need to do something to remedy it?  I didn’t install WD Smartware for either the new or old HDD.  I did install the SES driver for the new drive (as it failed to do this automatically), and when I plugged in the old drive again, it re-installed the SES driver for the old one.

Thankyou.


#2

It is always advisable to contact WD support personnel since you have a new device. If it becomes fruitless, come back here and state here their response.

Mabikay – SLK

Note: Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue.


#3

So you think that there is a problem?

How would I contact WD support personnel?


#4

http://support.wdc.com/contact/index.asp?lang=en

Mabikay - SLK