My Book essential update process seems to fail

I downloaded  the updates for firmware and software. Both files were unzilled as expected. Firmware ran forever and I cancelled it. then I unpluged the drive and tried to run the software update. same problem. It ran forever. What am I doing wrong?


Sounds like you were a little frustrated while trying to install the firmware just unplugging it during the update will make the drive unusable

I would suggest you return the unit

So you really didn’t give any help to the situation.  What if returning the unit as you say isn’t an option.  Neither is sitting the rest of eternity for the unit to not update the firmware as he originally tried to do.  The only option was to pull the plug after 6 hours of it trying to update 17 mb…cmon  the original problem wasn’t pulling the plug .  What was it…???

Okay, I got your point. Normal FW update would only take only one minute or two.  

Try this…

1)      Make sure your disk drive is visible on Device Manager. > Win Key + R then type devmgmt.msc >expand disk drive and your drive should be listed there. (Check the model #)

2)      If not listed; you have a dead or badly connected drive. Cannot continue!

3)      If drive is visible > type Win Key + R,  then type diskmgmt.msc > your drive should be listed on Disk Management. If not; Win Key + R then type CMD to start command prompt.

4)      In command prompt type mountvol /e and shut down your PC.

5)      Disconnect all USB drives and AC power cable or battery and adaptor cable it is a notebook.

6)      Wait for 2 min. and reboot. Go back to step 3. and assign “W” as drive letter for your drive.

7)      Now uninstall ANY antivirus program you have. Reboot again.

8)      Connect your USB device in question after completing start up. Now try to run firmware update utility downloaded from WD.

9)      If successful, reinstall AV.

10)   If all unsuccessful, return your drive and look for other brand/product.  

Sadly a significant number of people have problems with these updates. They start and it just sits there for long periods doing nothing and apparently corrupts the firmware and bricks the drive.


Hello new to site/forum,

Question - last night I updated the WD Smartware as suggested by the site with My Book plugged in. 

  • When it was finished updating I noticed that the “Backup” tab and the “Retrieve” tab were completely grayed out.  The only tabs I had access to was the “Home” tab and the “Settings” tab. 
  • Also, on my “Home” tab, after updating, I discovered that now my “Smartware” is not not recognizing “My Book Elite” as its not showing up on the screen.

I called WD support and they suggested either;

  •  I unplug the Elite for a period of 10 seconds then plug back into my desktop and reboot.  OR  
  • Install and reinstall the Smartware.  Question - if I go this path will I need to re-backup the entire full backup (yet again) or will the Elite recognize that a full backup has already been done.

Please help.  Thanks