My Book Essential Showing as RAW and wrong size on Windows 7


#1

Due to several problems with my XP machine I deciced to upgrade to Windows 7 over the weekend.  I had a My Book which I used fine on Windows XP.  it was purchased as a 1TB drive but when I bought it and listed it under XP it showed as being about 1.2 TB and also had the CD drive section showing as an extra 700 MB.  I thought this was a bit of a bonus as expected it to show as less than 1TB after install.

The drive was fine and before the Win 7 upgrade I backed up my data. 

After the install of Win 7 my drive is now listed as a raw volume and Win 7 also now shows it as 930 GB as well.  I’ve reinstalled the drivers, updade my drivers on my mobo and chipset and bios but all with the same result.

I’ve tried using testdisk and getdataback and these can see the backup of the MFT table on the drive.  The problem is the drive is now showing as a smaller size under Win 7 so I can’t restore the backup of the MFT as the drive is now too small!

I’ve contacted WD who suggested I format the drive, which i’m not going to do as I don’t want to lose all my data.

I’ve done some research and seems i’m not the only one with this issue after an upgrade to Win 7 but so far no fix seems to exist.  Has anyone got any ideas ?