My Book Essential no longer readable on my iMac

While my iMac (OS X El Capitan version 10.11) was in sleep mode the other day I stupidly unplugged my external hard drive from it in order to bring it somewhere. I should have properly ejected it but I didn’t and now when I plug it back into my computer it isn’t readable and I get an error message that says “The disk you inserted was not readable by this computer” and my options are “intialize” “ignore” or “eject.” I selected “initialize” and it brought me to disk utility:

I thought I would be able to just click “mount” in order to fix it but it is greyed out. So I tried running first aid and it told me this:

I don’t know what a partition map is or how to fix this issue, although it says “operation successful” I am still not able to access the files that are on my My Book Essential HD. Any help is greatly appreciated!!


It is possible the partition is corrupted. In this case you will have to format the drive in order to use it again. However, this will delete all data stored in it. If you need the data that’s on the drive then I recommend you use a data recovery software in order to recover this data before your proceed with the format.