My Book Essential freezes dad's PC

I bought a 1 TB My Book Essential for my dad since one of his internal Hard Drives recently failed.

He is running Windows XP, fully updated.

When I tried to install it, I plugged it in and it started installing its software onto his PC. After a minute or so, it froze at “25 seconds remaining” and stayed there for 20 minutes. I tried to eject the hardware, but the “safely remove hardware” utility froze when it tried. I then tried to open “My Computer”, but My computer came up as a blank window and had the hourglass.

After a few minutes, I used Ctrl+Alt+delete to close the installer since it was clearly not responding. I then had to shut down the computer manually since Windows wouldn’t do it.

Now, every time I plug in the Hard Drive it causes the same problems listed above, and I can’t install the software or uninstall the software. Every time I try to run the installer, it just won’t come up.

I can’t find any information on the website, and I don’t see any posts with a similar problem. Can somebody help me? I’ve had western digital products in the past, and have never had an issue with them until now. It seems like it’s the software that’s causing problems, not the hardware.

Well, try installing the WD SmartWare using the latest version. Click on the link below to download this software:


You can transfer files manually to the external drive. more info in the following link:

Note: And make sure that Net framework 3.5, Java, and flash player are installed on your computer.

Return the “Essentially – iniquitous” drive back to the point of purchase and get any drive doesn’t call itself “Essentials or Passport” … period.