My Book Essential doesn't work after reboot

I have a brand new WD 2TB My Book Essential.  It works fine if I unplug it an plug it back in, but after a reboot the drive is not present and the device is listed as not working properly.  I have a Gateway NV53 running Windows 7.  The device manager says the best driver is already installed when the drive is working.  I have no clue why this is happening.

Have you tried updating your Windows drivers?  Not switching to a different driver, but updating the one that’s there?

As far as I know, if the device actually weren’t working properly, you’d have different symptoms, and the message you’re getting is a Windows/driver issue.


I have the same issue, that my brand new WD 1TB My Book Essential does not show up, if the drive is connected to the USB2.0-port before switching on the PC or after rebooting. The device is the listed as ‘unkown’ in the USB-tree of the device manager in windows. I have a windows XP system, nforce 720i (MCP78PV) chipset, latest drivers are installed.

Also, I experience rather slow transfer rates with USB 2.0, only up to 10 MBytes/s. Once I tried the same external drive on a different computer, where I achieved easily up to 20 MBytes/s.

Is there any solution both the the boot/reboot and the slow transfer speed problem??? (Unfortunately I got no useful reply from the WDC support team).

I think I’ve found the solution. If your running newer hardware you may have a problem.

Here are my stats:

I’m running a i5-2000K on a Z68 Chipset, a Gigabyte GA-Z68A-D3H-B2 rev. 1.

I have an My Book Essential 3TB it would stop recognizing the drive on reboots and shut downs. It would just come up as a  Unknown Device. It seemed as my computer was posting it would slow down and the drive wouldn’t wait to be detected. If I unplugged and plugged it in on reboot it would detect it. If I didn’t the drive would either turn off, or stay on with a solid blue light. It would  then be detected as a Unknown Device and wouldn’t  work.

I am running it on a USB 3 Etron USB  controller built onto my motherboard. I’m using the Etron 104 driver as I had problems making an image of my drive using the latest 105 driver.

I solved the problem by changing a setting in my BIOS.  Under the Integrated Peripherals,  I disabled the USB Storage Function. Which is described in my motherboard manual as “whether  to detect USB storage devices, including USB flash drives and USB hard drives during the POST.”  The default being Enabled.

I disabled it and I have NO PROBLEMS AT ALL!

I hope this helps.