My Book essential can't update firmware


I followed the directions to update the firmware on my MyBook 1110 but after sitting and staring at the screen for 25 minutes I decided there was a problem.

I then went into safe mode with networking and tried the update.  It supposedly downloaded but wouldn’t install producing a message “close all open application”

What open applications?


I would suggest that you restart the computer and install the firmware update normally. What would be the reason for the firmware update? Here is a link with the proper procedure on the firmware update.

Someone said.   If It Ain’t Broke, Don’t Fix It.    Updating the drive’s firmware is not a requirement. :slight_smile:


That 's me I fried my video card last year grabbing the newest driver which turned out to be buggy.


I fried a sound card the same way, and that X-Fi was no longer on production when it happened :frowning:

Hi, I just wanted to comment on this intelligent observation. I totally agree with what you said Gabthemonster. My 1tb external harddrive is basically stuffed thanks to WD latest firmware and software update. My HD wasn’t broken and didn’t need fixing but I foolishly decided to update the firmware and software when prompted. I did everything that the recommendations suggested except to backup my data. 500gig approximately. All WD are prepared to do is replace my drive which I couldn’t care less about. They can do nothing to replace my lost data.

Basically both my laptops no longer recognise when I connect my 1tb passbook essential. I have tried different cables. One thing I did find though thanks to WD support  (lol) was that my computer still recognises the external drive in Device Manager but still no luck in finding the LOST DATA.