My Book Essential 2TB stopped working

I’m running Windows XP with a My Book Essential 2TB external harddrive as my main data storage and usage.  As luck would have it, I was just thinking to myself how I should probably go out and get another one so I’d have a backup. 

No sooner did this thought cross my mind, when the drive suddenly froze mid data transfer.  This sort of thing happened a lot when I first got the unit, and was easily fixed by either replugging the USB or restarting the computer entirely.  Neither of these was more than a minor inconvenience, and usually solved the problem after no more than a few attempts. 

This time, though, I’ve been using it for over a year, so I have plenty of information on it that I don’t want to format and lose.  I called Customer Support and it seems to be their knee-jerk reaction to tell me that the unit must be broken or defective.  I’d be more inclined to believe that if, when this was happening a year ago, the problem hadn’t then solved itself and been issue-free.  I have a feeling it just needs a stronger processor than the one I have to get it to recognize the system again. 

The THIRD time I called this evening, the tech suggested that I do a firmware update and as long as the update program recognizes my drive is attached, then there should be no physical problem with the drive.  Since this started happening a few days ago, every time I connect the My Book to the computer, it attempts to load the drivers as though it was the first time I had ever plugged it in. 

Sometimes the final message I get says that there was a problem during installation and that my device may not work properly until I reboot.  Other times I get the final message that the device is installed and ready for use (really??).  In either case, the drive does not show up in “My Computer”, “Disk Management”, or as anything more than “mass USB storage” in the “Device Manager”. 

However, despite it not being recognized by the OS as a usable drive, I’m encouraged that when attempting to load its drivers, the drive is recognized briefly as “My Book 1130” and when I try to use the firmware updater, the SN comes up.  This is good news.  The troubling news is that it is prompting me for a password.  I NEVER SET UP A PASSWORD!  I’ve tried every combination of every password I’ve used for ANYTHING in the past few years and nothing works. 

I stand by my original assertion that I never set password encryption.  Is there a standard generic WD password?  Is there a way I can get around this step so I can (hopefully) start using my drive again?  P.S. There is no hint listed for the password prompt, and I don’t have the money to buy a better computer with a more powerful processor, nor do I have ready access to one.  Please help, it is greatly appreciated

Thank you to whomever modified my post so it was a bit more readable.  Any thoughts on my ACTUAL problem?  I see a lot of people have read this, but no responses?  I’m getting quite frustrated with my drive.  I just want it to work again.

The password issue can come  from a bad firmware update. About the only thing to try is access the drive from a different user account like the guest account or another PC. There is no password reset.