My Book Essential 2Tb (1130) ... Where is the data ... Where are the partitions?

I have 5 external drives ranging from 1.5TB Elements desktops to 3TB MyBook Essential.  One of the drives as above the 2TB was successfully working as a 4 partitioned drive for 6 months when I then went on 2 month holiday leaving it lonely in a cupboard.

On return and trying to access it found that all partitions were erased and had no current backups.  The drive powers and is visible in Disk manager Windows 7 x64, with latest SmartWare and SES drivers.  All drive power saving, sleeping and hibernating is turned off.  As per best practices, powered off, shut down, restarted, tried different power plugs, power supplies and USB cables and  ports; all to no avail.

I then used some partition recovery software (takes some time on a drive this size) and thankfully selected the correct data paths and restored the partitions and data.  All was good for a week and 3 reboots, until the 4th reboot and bang the 4th partition was unformatted.  Fortunately had made backups by this time, but wondered what was happening.  On checking the WDC site found a firmware upgrade and proceeded to apply it bringing it’s version to the same as the 3TB (v1.016), believing this may make some difference and again things were good for another week till all partitions disappeared again (unformatted).

I have run the ‘Data Lifeguard Diagnostics’ on many occasions during the above which reports successful Quick, Extended and SMART(1 relocated sector) testing.

Changing tack, ran the WD QuickFormater and then repartitioned the drive into 2, formatted and partially populated them with data.  After the next full power-down the partitions were there but not formatted.

OK the big guns, ran the ‘Write Zeros’ of the diagnostics, powered down, reintialised the drive, set 2 partitions, added some data rebooted, but this time the entire drive was raw.

During the above incidents when I ran the partition recovery software, it managed to find the partitions and/or data although I no longer needed to (now had backup), was just interested if the drive held anything.

Yes this has become a bit of a novel, but I no longer understand  …  Help.

“I will never leave my drives behind when on holiday ever again !”

Hello Mate,

This seems to be drive corruption…Since you backup your data your cool. What you need to do now is get in touch with WD and replace your drive…

Hey thx Awopero, yours had to be the end solution.

But Then Again …
Not being a lover of ‘Warranty Returns’; again takes so long just to get a new (refurbished) drive. Kept using the drive - just didn’t reboot for 3 weeks - but then had to move rooms and once again, no partitions (Raw).
Went through the steps and at Power off, check cables,  found that the USB3 connector - though looking and feeling in - required removal and careful alignment on reconnection.  Further examination found the connector to move substantially with regard to it’s housing.  Procured yet another USB3 cable.

Long story short.  After 20 power downs, careful dis/re-connects, the results:

 - 17 successes, 3 failures.

Probably a lesson there.

It sounds like there may be a problem in the USB port or the solder connecting it to the circuit board.