My Book Essential 1 TB working very slow and sometimes fail to transfer files

I bought this My Book Essential 1 TB (for desktop PC) in 2010 and used it for few months for my HP laptop until I switched to MacBook. I learned that the drive can be formatted to be used in Macintosh system, so I tried that with Disk Utility and stuff and it worked.

However, few months after I did that, the drive started to reject files I tried to copy to it, basically the error code -36 that I have already researched on, and I got two answers; the problem lies on whether the drive is malfunctioning or broke down (need new one) or it was not formatted properly. I didn’t think that it is reaching it’s old age since I just bought the drive barely a year ago that time, so I tried to re-format it again as Mac OS Extended (Journaled) as usual. And again, it worked again, only for few weeks this time.

I got a lot of data on my drive, mostly videos and it is a very time-and-energy-consuming work to transfer the backup files to another computer, reformat the drive and transfer back to the drive. Out of frustration, I went to buy another one, however the store didn’t have Mac based drive, but they assured me that I can still use the drive properly if I reformat it to Mac based, like what I did on my first drive.

My second My Book worked properly and still is, however it is currently reaching its limit of 1 TB with only 43 GB left. I tried using my old My Book again and surprisingly it worked, and the old ailment doesn’t happen… until recently. The error code-36 appeared again and it won’t copy files. I tried to patiently copy one by one last week, and found out that the drive might not be broken at all. I copied two files; one failed with the error code-36 appearing and the other one was copied into the drive! When I looked closely, I saw that the USB cable to connect from the drive to computer has  a slight rusty surface on it, and I thought, it might be the problem, although it wasn’t rusty at all when the problem first happened.

Then, I was wondering if I could buy JUST the USB cable separately and WHERE? Online? In stores? Or is there any more method to find the roots to this problem and FIX it somehow? It’s just a waste to throw away a hard drive, especially when it’s not like it’s completely broken down. i would want to solve this by just buying a new one, but external storages are very expensive.

then, thanks, please anyone give any ideas to solve this. much appreciated!

p.s.  some words above i said might not make sense or sounds stupid, and if it does, i apologise since i don’t  know much about this area. 

you can get the cable here