My Book Elite not opening, not uninstalling

I need some help please! I’m running very low on memory on my laptop, so this morning I tried backing up some files through My Book Elite, but WD SmartWare didn’t want to open. It came with the message

“The application has encountered an unexpected error and is now exiting.”

It seems that this is a rather common problem, and I’ve read that I’d need to uninstall then reinstall it. So I go to programs and features to uninstall, and there are THREE WD softwares?

  1. WD SmartWare ver 1.5.1

  2. WD SMartWare ver

  3. WD Software Upgrader ver 1.5.1

#2 was successful in uninstalling. When trying to uninstall, #1 gave an error message of

“The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2753.”

When trying to uninstall #3, windows installer popped up saying

“The feature you are trying to use is on a network resource that is unavailable. Find an alternate path yadda yadda to the installation package ‘WD Software Upgrader.msi’ in the box below.”

I browse for the correct .msi, find it, but then it still says that it’s not the correct thing to uninstall the Upgrader…? What’s going on? How can I uninstall those two other programs and be able to use SmartWare to backup my files?


Well, my boyfriend found Microsoft’s Fixit program, and that worked in the uninstallation. However, when trying to reinstall Smartware, it won’t work. :confused:

When it finally started running, it showed another “network resource is unavailable” error box that called for Toshiba’s SD Memory Utilities.msi. I couldn’t find it on my laptop, so I just finished downloading it from here.

Ugh, just started installing it and got error message

"Internal Error 2229. , Control, SELECT ‘Control’, ‘Type’, ‘X’, “Y’, ‘Width’, ‘Height’, ‘Attribute’, ‘Property’, ‘Text’, ‘Control_Next’, ‘Help’ FROM ‘Control’ WHERE ‘Dialog_’=?”

and the whole thing just cancelled out. **bleep**. It.

Well, don’t know what to do now, so I’ll just see if WD’s download of Firmware works. -_-

Hopefully it’ll be an updated version too. If this doesn’t work perhaps then I shall just call WD Support.

Well, that didn’t work so I’ll try this found from another post.

Alright. That didn’t work very well. It terminated the connection and detection of my external hard drive. Basically this whole thread happened to me. Of course, uninstalling everything I just did was a given. It seems that upgrading the firmware screwed things up.

Strangely, disconnecting every plug from every plug and replugging back after a minute or so worked. My toshiba was able to detect the driver again.

I’m giving up right here on SmartWare. Seems like too much trouble for it’s worth. I’m just going to stick with the drag-n-drop method.

So whatever. Seems like nobody’s really following this post, so oh well. Maybe I’ll get something later.