My Book Elite 2.0 Firmware Fail

I just purchased this External Drive today.  I installed and it was all working fine. The WD SmartWare program said that there were updates available for it so I clicked which took me to the website to update. I downloaded the updater for firmware and went through the options. A minute or so in a box popped up with an error and my computer restarted before I even realized what was going on. Now, when I plug in the drive. It installs as an “Initio Combo Device Class” and is not detected under my computer as a drive. It is essentially an expensive paper weight right now and I can’t find a fix yet online. 

also, I have tried on several different computers and each one installs it as the “Initio Combo Device Class”. The main computer is vista and have tried it on 2 computers with XP and 1 other with vista.



1 Like

Same thing happened to me, and I can’t find answers online.

Same exact problem…everytime I uninstall and reinstall in device manager it keeps installing initio

the same thing has happend to me. it would seem i just lost 120 GB of data.

uh, a little help?

I just bought mine today on sale at Best Buy…I guess I’ll be returning it tomorrow

There is new SmartWare today…does this fix anyones problem. I refuse to update the firmware on this drive (I went back and got a replacement) until I know this is working…

Out of curiousity…did anyone here experiencing these problems have the password (in smartware) protecting their drive before updating the firmware (and didn’t remove the password before updating…). I did and I wonder if that’s whats locking the drives out…

I’ve escalated this thread to our product people.  Not sure what’s going on, but let’s see what happens.

I can add, that this has now happened on TWO drives. Both of them are the 1.5TB Elite drives.  BOTH brand new, and one tried on a MAC and the other a PC. After attempting firmware update (btw, I am a pc technician, not a noob) the firmware update bricks the drive. The drive no longer rotates and the display eventually fades out to nothing after a few hours. The drives are effectively dead at this point.

I have exactly the same problem.  My g/f bought me a 1TB drive which worked at first but after updating the firmware isn’t recognised on any computer.

I now have a shiny black paperweight.

#fail WD

I have the same problem and I did NOT upgrade the firmware.  Anyone out there in WD world that can help?  The external harddrive is useless now!

UGH I HAVE THE SAME PROBLEM WITH TWO OF MY BOOK ESSENTIAL edition 2 , my regular my book essentail works fine. [deleted]

Has anyone tried to contact WD’s Tech Support about this?  I would recommend it.

To Contact WD for Technical Support

I have a 1.5 T My Book essential and I got the same problem after updating the firmware.  I been in touch with their support people and all the can suggest is getting a replacement drive.  I find this fairly unnerving especially as I see on this problems on many other threads.  This is a obviously a widespread problem.  Why they persist in allowing this firmware update to be available in spite of  this common failure is beyond me.  

1 Like


What caused the problem, why not find an answer from technical support. Western Digital Community: !!

i have the same problem, since i decided to install the new smartware software (apparently 5 times faster then the old one…), i was advised to install the new firmware as well,  and now everythings gone… nothing works… 

the only solution i can think of  is to remove this new firmware and install the old one, but i just cant find it on the internet…


ediT: solved my problem by plugging my passport straight to motherboard. Bye now!

I’m having the same problem.

Purchased the drive, brought it home, plugged it in - everything went fine.

Noticed the update firmware button, pressed it. Went through the firmware install ok.

Went through the wd smarware install ok, but with two errors:

c:\windows\Microsoft.NET\Framework\v2.0.50727\culture.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support


error parsing c:\windows\\framework\v2.0.50727\config\machine.config

parser returned error 0xC00CE508

Now the drive isn’t recognized at all, and installs as an “Initio Combo Device Class” when I plug it in.

vista 64

let me know what, if any, additional information you require.

I have a 1TB My Book and have just had the same happen to mine. I had to change my motherboard in my main computer due to a failure and when everything has updated it has stopped recognising my My Book. It tries to set itself up and shows in the device drivers but isn’t listed in the Computer area of Windows 7.

I have also tried to put it back on my wifes laptop where it has been working fine and now it can’t find it either.

Surely there must be something Western Digital can do to rectify this problem. My “My Book” has all my Photo’s and files backed up onto it along with my music etc.

Surely there must be a way to wind the update back!!


My Essential did the same thing today.  I have contacted support and am waiting for a reply.  I will share what I get but after reading these messages I don’t hold out a lot of hope.  A replacement drive won’t recover the 2500+ songs on the drive.  I have a backup of the music that is fairly current but I will be missing about 50 tracks.  I have always trusted WD for internal drives, maybe there is a better option for external storage.

The support rep had a lot of suggestions which I tried.  The next to last was to attempt to reload the firmware.  I removed all other usb devices and tried again. Even though I could not see the drive in Disk Manager or Device Manager, the firmware update worked and the drive is back.  I am happy but would still rather have firmware updates work the first time without all the drama.