MY Book Drive I have owned since August last year still not working

CASE NO: 040313-683-3178

I am writing this in the forlorn hope that I might get a response from WD support. I have lodge requests to my current problem, on the WD Website but still haven’t got a response other that the automatic reply email (fat lot of good that is).

Firstly I made a mistake and bought a MyBook and had to ring because the back-up partition would not load.  WD Support could not fix it and eventually after much online support, the back-up partition was locked out by the WD support people (or it may have been stuffed when the drive was made …who knows!!!).  At that time they should have replaced the drive, but no the WD Support decided to load WD Back-Up Anywhere (or something like that).  It worked for a while until the first MyBook Update came through at stuffed my back-up on WD Back-up Anywhere.

Second go and I rang the support people again.  The time they agreed to replace the drive but I had to send it to Malaysia. I live in Australia.  So I sent it off to Malaysia, and if you have read the returns policy of WD, you have to send back the power cable.  So I did…worst mistake. 

Over two week ago I received the new MyBook drive and guess what, the power cable is a Malaysian power point (two parallel prongs) and doesn’t fit into Australian power point (needs two angled prongs).

As I have said I have raised a Case No, I have rung up, I have emailed … Let me think what have I got out of my investment in a WD MyBook…   NOTHING!!!

So here I am in May 2013 six months after the first stuff up by WD and still don’t have my network backed up. 

If they don’t see this post, my next step is to start posting on social media to see if I can get some response from WD.


Please check your Pm’s