My Book Data Access Issue

My drive has served me well for a few years.  Suddenly last month it stopped appearing in the file menu.  I tried it on another computer at home and still could not see my files.

I then took it to a local computer repiar place where they charged me $55, plugged it in, saw my files, and called me toi pick it up.  It mysteriously worked again for about three weeks.  Now it has stopped again.

When I unplug the power and then plkug it back in, I hear the drive whirring and the computer makes the “Ta-Da - I’ve discovered a device” noise.  Still, no data access.  Now, leaving it plugged in, it does the “Ta-Da” over and over, but does not reveal any files.

Please help.  Thanks!

Hi robincjohnston. Does the drive show up in Disk Managment? Have you tried changing the data cable? Also, make sure that you are connecting the drive directly to the computer and not through another USB device or USB hub. Another thing that I would try is unplug the power cord from the wall outlet and leave it unplugged for a few minutes, then plug it into another wall outlet if possible and see if that helps.

How to Access Disk Management

Thanks for your quick reply.

The device does not show up properly in Disk Management.  When I say “properly” I mean that, as it cycles through its startup sequence and tries to fidn the data, it temporarily flashes on the screen for literally a millisecond or less as my computer makes the “Ta-Da” sound, then it disappears again,  In each cycle, I can hear the drive spool up, see the blue light come on, then hear the “Ta-Da” and the cycle repeats.

I had already tried unplugging the power, and just tried a new data cable.  Neither worked.


Are there any other alternatives?

It sounds like you’ve done pretty good at troubleshooting it already. The only other thing that I can think of to try is to use another power cord in case this one isn’t working properly. If you have another WD product, you can check the power adapter, most My Book drives use the same power output so the power supplies are interchangeable. If not, You can try purchasing one through our tech support (if its available in your region since I’m not sure where you are located.

Otherwise it sounds like the drive may have failed. If you need the data on the drive then you may need to check with a data recovery company to see if they can retrieve the informtion for you.

Contact WD Support

Data Recovery Partners