My Book 4TB External as Internal (Already wiped)


I would’ve done this on another existing thread, but all the ones I’ve found for this talk about saving existing data. In my case, there is no existing data.

When the owner of the drive brought it to me, she said that it was no longer under warranty, and the drive was not being recognized. This was confirmed when I plugged it into my own computer.

As it turned out, the bridge board was fried, so they purchased an identical bridge board off ebay, which worked to allow me to move her data to another drive.

Due to the seemingly high-ish rate that these WD bridge boards either break, fry, or otherwise fail, (which causes the drive to be pretty useless) she has decided to never buy WD external hard drives again, and asked me to do away with the external casing all together, and turn the drive to an internal one.

Using a combination of Windows 10 Disk management, and EAS Partition Master, I’ve managed to remove all partitions, convert from MBR to GPT, and put a new partition on the drive. Problem is that running chkdsk on the drive says all sectors fail surface test after about 69% (Roughly around where the end of the first MBR partition would be)

I can write, modify, and delete files placed anywhere in the first 68% of the drive, but i have not dared to add enough test files to fill past that point for obvious reasons.

In Linux, I get errors when trying to partition the drive at all.

There is no data to recover, and I simply want to eliminate the need for the bridge board. Is there something else that I need to do in order to correct this problem, and allow the drive to be used as an internal one?

Hello there,

I have not tried this since i have not experience this, lets see if another user can share some information or tips on this matter.

As an update to this, Linux appears to be able to create a two partitions on the drive… first is 2TB exactly, and the second is the remaining free space, but yet I can’t make one partition that takes up the entire disk.