MY BOOK 2 NOT MOUNTING IN MACBOOK (White), OSX 10.5


#1

Hi,

I desperately need help, with a capital H. I have a My Book Studio 2 (2 Terabyte external). It used to work fine for a couple of months on my Macbook but now for some strange reason, it’s not showing / getting recognized by my Mac at all…via Firewire 400.

When connected, Disk Utility doesnt show the drive, I tried changing the adapter thinking the original one may be faulty, I’ve tried updating the firmware via USB (but that does not happen because it cant verify). Nothing is working.

The Drive does get powered up but  and the harddisks are producing a very low audible hmm sound, but i’ve noticed that the centre light just goes up and then it becomes normal, it doesnt read the way it used to, back then the light would go up and down two times and then disk would be mounted.

Need urgent help !!! Thank you. 


#2

hi…

same problem whit my mybook essential… in my mac it stop responding

it’s half filled but… when i connet to usb plung nothing happen, or in my PC… tray to upnplug and wait, when i plugin just make sound and litle blue led is online whine after that it goes in some standbuy and nothing happening…

on my diskutiliti is not showed…

any help?


#3

I am also having the sam problem with my 1.5TB…someone please help


#4

The easiest way to find out is to make sure the WD external drive gets the power:

a. Try it with a known good 12V 1.5Amp AC adapter.

b.  Make sure the WD external drive spin up or make some noise or the LED light lit up.

c.  If after tried that and the WD external drive is still not recognize by your computer.

     Could you try hook it up with an USB cable?

     If  after tried with USB cable and the WD external drive is still not working.

d.  You would need to contact WD technical support for further help.