My 7-month old Passport cannot be seen on Windows or Linux

A 2 TB Passport that I bought 7 months ago, which had been working perfectly, suddenly threw an error on a download overnight. When I tried navigating to the folder using Windows Explorer, I got this error: “The request failed due to a fatal device hardware error.”

Initially, I was able to move to another folder without issue. My PC was also showing the right amount of remaining space on the drive (310 GB).

I did a search and followed the instruction to update drivers. The Device Manager said the driver was up to date. I then tried to run a scan and a scan and repair via Tools, but both failed. I tried a SMART scan through CMD and the status was OK.

I went ahead and disconnected the drive, then attached it again. By then, it was not showing in Explorer. It’s detected in the sense that I can safely eject it, but it’s listed as uninitialized under Windows Drive Management. An attempt to access the drive through the Linux Mint Terminal failed as well, as the device does not recognize that there is a drive attached at all.

Minitool Partition Wizard and Minitool Power Data Recovery see it as a 512B drive, with no partitions and a basic MBR, while the WD Data Lifeguard Diagnostic Tool does not even reflect the drive in the dropdown.

I changed cables, plugged the drive into different ports and different laptops, and have had zero success accessing it. When I plug it in, I can feel the drive spin for a moment (no clicking), but then it stops and does not spin, though the light remains on.

There are sensitive, important files in the drive and so I’d like to recover them if possible.

Are there any other options I can try?

Thank you!

Hi @Bex,

There could be a few reasons why the drive is not showing up under Computer. The drive itself could have failed, the partition on the drive may be damaged, the data cable may no longer be good, or the drive may no longer be getting enough power to fully spin up.

Please refer to the following article for troubleshooting steps as the drive is not getting detected:

Link: Windows or macOS Cannot Find My Drive

If the drive is getting detected, I would suggest you to test the drive health status through WD Drive Utilities.

Link: How to install WD Security & WD Drive Utilities

If destroying their data is the goal, it might just do that. Please stop posting your Stellar spam. If you want to actually read the user’s post and give actual advice, that is one thing. But all your advice is absolutely horrible.

Sadly, the drive is just not detected at all. Trying to initialize it in Disk Management (even accepting file loss), does not work either, it just returns to the “request failed due to fatal device hardware error.”

Hi,

We appreciate that you had done all the possible troubleshooting for this issue. As per the details shared, we see that you are getting a ‘fatal device hardware error’.

I would like to inform you that, this error is most commonly provoked when:

  1. The hard drive cable is faulty. If the cable is faulty, the data cannot be transferred hence the computer prompts the error message.
  2. There are bad sectors in the disk. There can also be corruption and wrong mappings.
  3. If the cable isn’t faulty and the hard drive is showing the same error message in all computers, it probably means that there is a hardware fault in the hard drive.

Also, please be informed that initializing the drive will erase all data on the drive and is not recoverable. In such a scenario, kindly connect the drive with a different known working USB cable and USB port on the computer.

If still, the problem persists we suspect that there is an issue with this drive, and also the issue can’t be fixed as it’s a hardware issue and needs to be replaced.

You should try contacting WD’s Technical Support.

To Contact WD for Technical Support

support.wdc.com

Thanks for sharing. I found a lot of interesting information here!