My 1TB Western Digital My Book World Edition Has Stopped Responding


#1

My 1TB Western Digital My Book World Edition will not respond.

I have tried to reset it with no success (I think). Held reset button for 10 seconds after turning on power but still no response.

The white light on the front sits at the bottom of the device and does not move. When I try to access with my computer it can not find it on the network. My PS3 can see it but no access any files on it.

I have tried to rediscover the device with the WD Discovery software but it can not find  any devices on my network. I have plugged it directly to my laptop through the network cable but nothing happens and it does not appear in my computer.

Does anyone know how I can get access to my drive again? I would prefer not to lose data but if that is easiest way to fix then that’s ok.

Thanks,

Andrew


#2

Hi Andrew

I am having exactly the same problem. I have over 400gb of data that I can not see. My PS3 shows the empty drive. On my Mac I cant access my drive at all.

I think it has something to do with a missing / lost volume. I have tried data recovery software but it can see the network drive.

This all happened when my mate tried to access the drive on his windows laptop. He couldnt find the drive so he used the WD software to Map the drive.

Any help??


#3

Thanks for the reply

I have tried to use the WD software on my usual laptop without any luck. I will try a different computer to see if it can see the drive.

I will let you know how I get on.

Andrew


#4

Still can not access or see the drive on any compter.

I am using Vista and my flatmate has Windows 7 and both can not see it on the network.

Even if I plug in using a network cable my computer can not see the drive.

Any ideas?


#5

Hi Andrew,

I am having exactly the same problem. I have over 600gb of data that I can not see. On my Win7 I cant access my drive at all. On my Mac I cant access my drive at all. Still can not access or see the drive on any compter.

How would you fix the problem?


#6

I am having a similar problem.  I recently had a power outage and after everything reset I wasn’t able to access my WD MY Book World.  I tried reseting it as well but have only got as far as seeing it on my network but still can’t access the files.  Has anyone found a solution for this?


#7

I do have the same issue with a 2T system, is anybody knows the answer for this issue? I tried calling Tech Support but has no answer to this issue. At least I want to be able to get my data back.

Thanks


#8

I am having the same or similar problems - and on the same day I installed it!!  So if anyone can advise what to do in these situations that would be greatly appreciated!

When I installed my MyBook World II 2TB (as per Quick install guide) on my Win7 PC it didn’t find the drive straight away.  I had to disconnect it from the router and then plug it in again, and then do a reboot before it mapped the drives properly.

My PS3 saw it straight away but it took a few attempts of running WD Discovery on my WinXP laptop before it mapped the drives.

I attempted to copy a 700mb file to one of the shared folders on the drive but about 3/4 of the way through the copy stalled and I then got an error saying it couldn’t access the network drive.  I eventually cancelled the copy and since then it hasn’t mapped the network drives on either computer and the PS3 no longer sees it.  The white light on the front is sitting at the bottom and not moving.

Attempted troubleshooting so far:  I’ve tried holding in the power button but this doesn’t do anything. I’ve disconnected/reconnected the power from the rear. I’ve rebooted the PC. I’ve disconnected/reconnected the LAN cable (my router lights up the corresponding port it is connected to, and the NAS has a green LAN connection light on the rear, however the activity light is not lit - but this could be because the drive isn’t doing anything).  None of this has worked - WD Discovery still won’t see the drive.

Very frustrating!! HELP!

Thanks,

-GT


#9

When you power the unit up after removing the power lead, does it come on then go off. This may sound stupid but did you then press the power button on the back of the unit  this should power it up. M PS have a look at this.

http://community.wdc.com/t5/My-Book-World-Edition/WD-World-Edition-white-light-freezes-locks-up/td-p/99198


#10

Thank-you for taking the time to respond.  :smiley:

Last night I turned it back on from the wall and it powered up and stayed on.  WD Discovery then even found the drive and it seems to be working again!  Solutions like this don’t fill me with confidence as I haven’t really done anything to fix it other than have it powered down for 24hrs - so I’ll have to see how long it lasts this time.  In any case I updated the firmware while the going was good so hopefully that sorts it out.

But to answer your question, M, when I powered it up the other night it appeared to be on as the bottom of the white lights was lit and the fans inside were going -  but nothing was seeing the drive.  I couldn’t power it off using the button on the back as that didn’t seem to do anything.  The user manual says to power it down you need to hold that button in for 4secs, however nothing happened when I did so.

I did have a look at that post when browsing around for solutions yesterday but some of it is a bit over my head so I won’t attempt anything unless I really have to.

Stay tuned in case it goes belly-up again!!

Thanks again!

-GT