Mt. Lion upgrade causing problems with WD Elements

Hi all!

I have a 2011 iMac. The iMac and the WD Elements are connected to a energy saving surge protector. The iMac is plugged into master and the WD Elements, along with my speakers and printer, are plugged into the servant plugs. (Meaning, when the iMac/Master goes to sleep, everything else goes to sleep as to save energy.)

Yesterday, I upgraded from Snow Leopard to Mt. Lion. Since upgrading, after I wake my iMac up from sleep (and therefore, WD Elements has also been asleep), I get the error that the disk was not ejected properly. After spending significant time with the Apple folks, we narrowed it down that the iMac thinks the WD Elements has been ejected when really it’s just asleep.

In system preferences > energy saver, I did uncheck the box for “put hard disks to sleep when possible.” However, that didn’t fix it, most likely because of the energy saving surge protector. I also checked the USB cable (replaced with a new one). That didn’t fix the problem either.

I did NOT have this problem previously when I was on Snow Leopard. It started almost immediately after upgrading to Mt. Lion. 

Has anyone else had this problem? If so, is there a fix?

I’d prefer not to change to a plain old surge protector and I’d prefer not to leave the “put hard disks to sleep when possible” unchecked. I will if I have to, but I’m hoping there might be another fix. I looked through the support, but didn’t see any similar issues. 



This means that it works fine if you have it plugged into a normal surge protector?

1 Like

No, I actually hadn’t tried it - mainly because I didn’t own a regular, plain old surge protector. But I went and bought one and it seems to have fixed the problem. Although I still don’t understand why it became a problem. Everything worked fine on the smart surge protector prior to the upgrade. 

I have a mid 2011 imac too

Two FW800/400/USB2  disks, model wd4000mt

usb work fine.

fw800 not work very well in lion and mount lion in my mid 2011 imac

via port fw400 in my old imac and macbook with snow leopard work fine