MP4's

OK…by a quick perusal of this forum, I see I am certainly not the only one with a problem playing MP4 video files.

I recently got the MyCloud 2TB.  Yes, I got it to be able to have a networked storage drive to be accessed from wherever I am, but, I also got it to be able to have video files on it so at my home I can stream videos from it to my SMART Blu-ray player/ television.

I’ve already done streaming via my desktop computer (Windows 8.1 OS) to my Blu-ray/ television.  But when I try the same video files that I can successfully stream via my desktop PC, it fails via the MyCloud.

I can “see” the video (MP4) files when I peruse the contents via my Blu-ray/ television from the MyCloud, but when I select the video file to Play it…I get a message on-screen that says “Cannot play this file”.  And this is not just one particular MP4 video file of mine; it is _ many _.

I wrote to Western Digital tech support, and so far their suggestions have been:  1.)  Reset the device by using a paperclip in the slot/ button at the back of the unit; did that, problem still remains.  2.)  Download & install MediaInfo software program, run it, and save the results as a Text file and send as an attachment to Western Digital tech support; I did that and am awaiting a reply.

In the meantime while awaiting a reply from WD tech support, I thought I’d post a message here.  And as I saw in another message posted on this forum, I’d agree with the posting that I saw that the problem is probably not the MyCloud device itself, but rather the Twonky media server.

But anyway, while waiting for the tech support reply…anybody have any suggestions?  Ideas?  Something I could try to see if these video files (MP4’s) can play?  Something other than converting these files to another video format  :manmad:

Thanks for any help,

Pez

What are the audio codecs you encode your MP4 with? If you have AC3 tracks, that could explain why they don’t play on all players, for example

Hi Etupes; thanks for the reply.

Using that MediaInfo program Western Digital suggested, here is the Audio text info from the MP4 file:

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : 40
Duration : 8mn 16s
Bit rate mode : Variable
Bit rate : 107 Kbps
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 44.1 KHz
Compression mode : Lossy
Stream size : 6.34 MiB (3%)
Encoded date : UTC 1970-01-01 00:00:00
Tagged date : UTC 1970-01-01 00:00:00

Does this info help?  Can you tell anything from it?

Pez

Yeah! Your files are good from a codec perspective, so this is not the problem.

Another possibility is that the DLNA library of the NAS is out of date for some reason. So the DLNA server still lists the file, but it cannot find it when the play wants to start streaming.

To fix this, you can tell the Twonky server to rescan and rebuld the database. This is possible by accessing the Twonky server settings through a browser at 192.168.1.100:9000, for example, if 192.168.1.100 is the IP address of your NAS.

Hi again.

OK, I’m at the Twonky server page, but, am not exactly sure where at on this page to “rescan and rebuild the database” as you put it.

Here’s a pic of the page:

TwonkyServer.jpg

On the left-hand side if I click on “Advanced”, there are some buttons that say “Restart Server” and “Rescan Content Folders”, but I already tried clicking on them to no effect; the MP4 videos still won’t play.

Are those the buttons you meant by “rescan and rebuild the database”?

Pez

P.S.   BTW…on that Twonky server page, there’s a “help center” hyperlink down the bottom, but, rather disconcertingly, it gives this message:  “Sorry, the community you’re looking for has been retired and is no longer available.  If you need help, please contact the company you’re looking for directly.”

You have done the basic troubleshooting with Twonky.

So to be clear, the same file can play when it is shared by Windows media Player DLNA to the Blu-ray player, but it doesn’t play when it is the NAS serving it?

Yes, you’ve got it:  if I use my SMART Blu-ray player/ television and access my Windows OS (DLNA), the video file (MP4) plays just fine.

If I take this _ same exact file _ and copy it into my MyCoud Public\ Shared Videos, and then use my SMART Blu-ray player/ television and access the NAS (MyCoud) and try to play this file…I get the on-screen message of “Cannot play this file”.

And just to let you know, do you know what I just did?  Besides already trying to reset the device (paperclip in the slot/ button on back of unit for about four seconds), I did a complete reset of the device back to Factory Defaults.  That took a while!!!  ;-)   But it was all for naught:  I still can’t play the MP4 video file.

I’m still waiting to hear back from WD tech support via e-mail.

Any other ideas/ suggestions until then?

Pez

Errr not sure of your issue but the rescan from twonky’s gui doesn’t always works for me even on the latest v4. The issue I’ve been having is missing newly added subtitles. But below works.

From the wd dashboard -> settings -> media -> dlna database -> rebuild. This calls twonky’s api http://wdmycloud:9000/rpc/rebuild (I mobile book marked this comes in handy) which is the same as deleting the database and rebuild. 

Hi Nazar78; thanks for your input.

Yes, I already tried the WD Dashboard: -> settings -> media -> dlna database -> rebuild.  MP4 video file still won’t play when I try to access it from the MyCloud via my SMART Blu-ray player/ television…Do you think this is a problem with the Twonky media server and not the WD NAS device itself?

Besides using Windows’ built-in sharing/ DLNA, I also have Plex software installed and I sometimes use that.  So when I turn on my Blu-ray/ television, I see three items listed now: Windows, Plex, and MyCloud.

The Windows file sharing/ DLNA and Plex will play any MP4 files just fine, but if I access that same file - MP4 video which I copied over to the MyCloud - it won’t play it and I instead get that message: “Cannot play this file”.

Why the heck is this MyCloud/ Twonky having trouble streaming/ playing MP4 files?!?!  It’s not like MP4’s are some relatively new type of file; they’ve been around for years!!  :wink:

Pez

How did you encode these files? Do you know the H.264 profile that you used? Maybe the resolution?

Second Etupes questions.

Just to rule out, have you tried grabbing mp4s off the torrents and tested? E.g. I’m following Mentalist series, this file I just watched “The.Mentalist.S07E05.HDTV.x264-KILLERS.mp4” has no problem playing on all my samsung tv/blu-ray/tab/mobile from twonky.

Maybe also you could scan through the log for errors: /CacheVolume/twonkymedia/twonkymedia-log.txt

If nothing, try turn up the verbosity in the settings “/CacheVolume/twonkymedia/twonkyserver.ini” then restart twonky and see if you could spot any issues in the log while attempting to play the specific mp4.

Last resort to rule out twonky or wdmycloud issues but if you’re comfortable with modifications, checkout MiniDLNA from my signature.

OK…I finally heard back from Western Digital tech support.

Even though I had contacted them by e-mail, they requested a telephone call.  They ended up calling my phone, and during the call, we did a remote connection to my computer from theirs so they could see what was on my PC.

Bottom line?  It must have been something basically screwy with the codecs of certain MP4 files I was trying to play.  Some of the MP4 files I tried to play would actually play, but so many would not.  They “appeared” to be the same type of MP4 files, but evidentially, when the WD techs looked at the MediaInfo text file I sent them, they saw something that was questionable.

So, I converted (or, really, just re-converted) the MP4 files I was having trouble with.  They now play.

And the converter I used?  You know how there’s a YouTube downloader software program?  Well, that very same program has a video converter built-in.  I used that to convert the files.

Even though I loaded up the MP4 file into the YouTube converter, the type of file I converted it _ to _ was not “technically” another MP4 file.  From a drop-down choice menu, I chose “XVid MPEG-4 Codec (AVI)”.  After converting, this was the file type that would actually play from the MyCloud streamed through to my SMART Blu-ray player/ television.

If you’re familiar with it, the YouTube converter has other choices in its drop-down menu, including many for Apple/ Macintosh products, file types such as “Ipad Video (MPEG-4 MP4)” [and also Ipod and Iphone].  I actually tried the “Ipad Video (MPEG-4 MP4)” first, but that wouldn’t stream/ play when I attempted it.  I would get the message on-screen of “Cannot play this file”.  I could play this file on my desktop computer, but not stream it from the MyCloud to my Blu-ray/ television.

The YouTube downloader/ converter is an “OK” program…but does anyone know of a better video software converter program?  One that could convert into a _ quality _ MP4?  It would be great if it was freeware!!!  ;-)  But if you know of one that’s fairly inexpensive, I’d like to know about that, too.

Thanks for all your input everyone.

Pez