Movies not appearing in my Media Library - TMDB related issue?

I am down to six movies that are on my hard drive but will not appear in my media library.  My meta source is the default, TMDB, and these films are all listed in TMDB.  I have the most recent update intalled.  I have tried adding to the alternate title list in TMDB and have tried renaming the file.  Renaming the file worked for a few but not these six.  The one I am most eager to fix is Alien Resurrection to complete the 4 movie set and have tried renaming the file as below to no effect.

Alien Resurrection

Alien - Resurrection

Alien: Resurrection


Alien 4

Any suggestions to fix this?  The others that I remember are

A Very Long Engagement

Naked Ambition

The Past

The Tough Guys

Salo, or the 120 Days of Sodom


I’m confused about your issue.

Whether TMDB is “working” or not should have no bearing on whether files appear or not.

TMDB only provides metadata.    If, for whatever reason, the WDTV can’t get the Content Info for the movie, it should still be listed – it’ll just be listed by the filename.  (Of course, you need to have the FILTER set to something that doesn’t require media Info.   “By Folder” will always work.)

So if it’s not being listed at all, then there’s something else going on.

If it IS appearing (but by filename) then just doing a manual Get Content Info via the Options button should allow you to find it.

The movies appear if I turn off Media Libray under the Video icon or I can see the files if I use the Files icon.  But with media library turned on the movie will not be listed with out the metadata downloaded from TMDB.  For some reason the Get Content option is no longer available as you suggested.

Other than what I mentioned above, I have no idea what your issue is, then…

My Media Library is full of videos that don’t have TMDB data on them…  and they all show up fine.

Home movies and such will never have content info – if they didn’t display, the player wouldn’t be of much use.

Strangly enough a new firmware update became available today and now allows me to manually add content information.

Problem solved.