Moved and Now Network is Screwy

Hello all, I will be as detailed as possible to get the best answer possible.

My main “desktop” computer is an iMac 27" with the latest OS installed.  I have attached to it a netgear router from Cox Cable, model: CG3000D.

Everything in the house runs via the router’s wifi.  Two smart tvs, two ipads, two iphones, my printer, and of course, the MyBookLive 2TB.  

The MyBook is wired directly into the router.

Before moving and subsequently changing my router (Cox said I should), I was able to pick up the MyBook via the “network” link on my Windows 7 Laptop as well as my girlfriend’s macbook pro.  We used XMBC to play movies onto our television that it streamed wirelessly.  

For some reason, the laptops are no longer accessing the MyBook.  Before the MyBook gave itself an IP address of .16 and now its .09     I can access the files/folder via the iMac but not through the laptops at all.   Why is this network discrepancy happening?    Also, I’ve changed the XMBC folders to link to .09 now, so they find the files, but seem to have trouble accessing them.


To begin the DHCP server  is responsible for assigning addresses to all the devices on the network so your seeing the my book lives address moving around because that’s what’s being assigned based on availability if you would like to have a static address (that is an address that never changes) you can set it via the dashboard web UI under settings, network, LAN configuration.

Secondly I had the exact same problem at first, I first purchased my MBL none of the wifi connected devices on the network were detecting it. This is definitely a firewall issue your having you need to determine if the routers firewall is responsible for this or if its the firewall on the clients themselves. You have a few options I’d start with the router since its easier.

  1. Connect one of the laptops to the router via Ethernet cable if the laptop can access the My Book Live it means its your routers firewall that’s filtering out the traffic. If this is the case about 90% of the time factory resetting your router will do the trick. If that fails add a rule or lower the firewall settings. If that doesn’t help proceed to number #2

  2. If you connected the laptop via Ethernet cable and it still isn’t detecting the my book live add a firewall rule on the laptops firewall.

Please let me know if I was of any help and don’t forget to hit the kudos button as a way of saying thank you also mark my post as a solution if it solved your problem so that others that are experiencing this issue can come here for a solution.